Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 15 jul 2020, 01:01



Svara på tråd  [ 13 inlägg ] 
 Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu10.04 
Författare Meddelande

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
 Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu10.04  Tråden är löst
Till att börja med så är jag ny på Ubuntu, därav behöver jag säkert en massa tips/har säkert missat något fatalt.
Jag har byggt mig en HTPC (med Zotac ION F-series som grund) där jag installerat Ubuntu 10.04 + XBMC Live vilket gick rätt bra och utan problem. Jag har dock stött på enorma problem när det gäller min trådlösa uppkoppling till HTPC:n. Till att börja med kopplade jag in trådbundet nätverk och laddade ner alla uppdateringar som fanns från uppdateringshanteraren (eller vad det heter) + installerade Nvidia grafikdrivrutiner (som den hittade själv, riktigt hur förstår jag inte eftersom jag inte stoppat in nån CD då). Trådlösa nätverket verkade inte fungera så bra märkte jag direkt då datorn bara hittade det trådlösa mitt modem sänder ut, förutom ibland då den hittade mitt trådlösa nätverk från min router. Jag är tusen procent säker på att det inte är något fel på nätverket/för svag signal där datorn står eftersom jag har massor av andra prylar som använder trådlösa utan problem i hela lägenheten (bla ps3 och wii som står precis bredvid HTPC:n). Då började jag googla på vad som kunde vara fel. Installerade ndiswrapper och laddade hem drivrutiner för trådlösa nätverkskortet från Zotacs hemsida. Har nu testat med drivrutiner från både CD:n som endast var windowsanpassad från Zotac samt med en massa olika drivrutiner från hemsidan (WinXP, WinVista osv). På vissa drivrutiner står det att hårdvaran finns på HTPC:n när jag installerat dom med ndiswrapper, fast på några andra står det att hårdvaran inte finns på datorn. Ett tag fick jag faktiskt nätverket att fungera, men det gick extremt långsamt (har 100mbit och det gick i ca 0,5 mbit). Efter ett par minuter dog det sen. Började då rensa och tog bort de drivrutiner som inte fanns på datorn. Ingen skillnad.. Startade om flera gånger och fick tillslut datorn att felsöka hårddisken vid varje uppstart och gnälla över nån av drivrutinerna jag pillade med (började lika Windows mer och mer..). Fick tillslut bort felsökningen genom att avinstallera ndiswrapper och alla drivrutiner. Efter detta finns inte ens trådlös anslutning som alternativ uppe i högra hörnet på ikonen! Nu börjar jag bli extremt trött eftersom jag inte ser logiken i vad som händer. Avinstallerade då grafikdrivrutinerna och fick tillbaka trådlösa nätverket som alternativ. Dock så fungerar det såklart inte att ansluta, den står bara och söker när jag skriver lösenord osv. Installerade då tillbaka grafikdrivrutinerna igen och fick trådlösa nätverket att försvinna igen. Som ni märker går det inte så himla bra för mig. Hade trott att det bara var att installera och köra på med Ubuntu. Otroligt störande också att allt är kopplat (hjälp + uppdateringar m.m.) till internet när man inte kommer åt internet. Själva meningen när jag köpte HTPC:n var ju att det skulle vara trådlöst och bara fungera.
Har även fixat openDNS eftersom avahi-identifieraren gnällde vid uppstart efter ett tag. Den har jag dock fått bort efter detta. Först trodde jag att avahi var problemet, men det har inte löst nånting alls efter att jag fixat openDNS.

Nu får jag snart damp och skiter i Ubuntu. Orkar inte hålla på och pilla med nåt som ändå bara är inkonsekvent och aldrig funkar. Visst är kanske windows inte perfekt, men där brukar grejerna funka tillslut. Jag är således desperat efter hjälp!! Har googlat som sagt och läst nånstans att Ubuntu 10.04 har nån bugg eller nåt med det trådlösa? Är mycket tacksam om någon kan hjälpa till!


20 jun 2010, 02:39
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
testade detta nu också, utan framgång:

sudo aptitude install linux-backports-modules-wireless-lucid-generic



Jag kommer typ gråta mig till sömns nu. Ska det verkligen vara så svårt att få allt fungera? Om det är så att jag valt fel version av Ubuntu eller nåt så får ni gärna säga till. Jag tänkte att den nyaste är väl bra och borde såklart fungera utan problem, jag bryr mig nog egentligen inte så mycket om vilken version jag har. Kommer ändå använda XBMC mest på HTPC:n (+ torrentnedladdning).


20 jun 2010, 03:02
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Tyvär kan det vara så här svårt med vissa nätverkskort :( speciellt eftersom en del inte fixar till drivrutiner för linux. Många kort kan man få igång med windows drivrutier och ndiswrapper.

Det är lättare att ge tips om man vet vad det sitter för hårdvara i maskinen. Kan du lista resultatet av terminalkommandot lspci här?


20 jun 2010, 09:14
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
johannes@Johannes-HTPC:~$ lspci
00:00.0 Host bridge: nVidia Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: nVidia Corporation MCP79 LPC Bridge (rev b2)
00:03.1 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: nVidia Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: nVidia Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: nVidia Corporation MCP79 Co-processor (rev b1)
00:04.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB Controller: nVidia Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB Controller: nVidia Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: nVidia Corporation MCP79 PCI Bridge (rev b1)
00:0a.0 Ethernet controller: nVidia Corporation MCP79 Ethernet (rev b1)
00:0b.0 IDE interface: nVidia Corporation MCP79 SATA Controller (rev b1)
00:0c.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:17.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
00:18.0 PCI bridge: nVidia Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: nVidia Corporation ION VGA (rev b1)
04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
johannes@Johannes-HTPC:


20 jun 2010, 10:33
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Det kortet borde fungera... Men det har varit problem med det i tidigare versioner. Då har lösningen varit att installera backports moduler för kärnan.
testa att installera linux-backports-modules-wireless-lucid-generic och se om det hjälper.


20 jun 2010, 12:32
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Jag hade ju redan testat det (skrev det i andra inlägget).
Gjorde ingen skillnad.. Så vad ska jag göra nu då? Kasta ut skiten från balkongen..?


20 jun 2010, 12:51
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Testa wicd. En del för igång nätverket med den istället för networkmanager.


20 jun 2010, 13:11
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Du får gärna förklara mer exakt vad jag ska göra. Eftersom jag aldrig haft Ubuntu innan detta så är jag inte så haj på alla termer..
Med andra ord, beskriv gärna exakt vad jag ska göra.


20 jun 2010, 13:51
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
instnallera wicd
stoppa networkmanager
starta wicd

om det fungerar får du avinstallera networkmanager. Det är ingen bra ide att ha bägga igång samtidigt...

Det korta och koncisa terminalsättet.
Kod:
sudo apt-get install wicd
sudo stop network-manager
sudo /etc/init.d/wicd start
wicd


20 jun 2010, 20:01
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
funkade inte så bra med wicd heller, den hittar inga trådlösa nätverk.
network manager brukade kunna hitta 3 st. Men eftersom jag bor i lägenhet så bör det kunna hittas ca 10 st, de andra datorerna jag har gör det direkt..

jag skulle gärna vilja ha kommandot för att avinstallera network manager. ska prova med att lägga in (windows)drivrutiner från zotacs hemsida genom ndiswrapper nu.

några andra tips jag kan prova med?


23 jun 2010, 20:32
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Yllert skrev:
jag skulle gärna vilja ha kommandot för att avinstallera network manager. ska prova med att lägga in (windows)drivrutiner från zotacs hemsida genom ndiswrapper nu.


sudo apt-get remove network-manager


23 jun 2010, 20:39
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
nix, funkar inte alls!
wicd hittar inga trådlösa nätverk alls.. Man kan ju söka efter dolda nätverk oxå, där den frågar efter ESSID tror jag det stod. Visst är det samma som SSID (alltså namnet på nätverket)? Det funkar iaf inte att söka på det namn mitt nätverk har heller.. Inte för att mitt nätverk är dolt, men ändå..

Fortfarande jättegött om någon kan ge mig tipset som gör att det funkar!


23 jun 2010, 21:01
Profil

Blev medlem: 29 maj 2010, 15:09
Inlägg: 10
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Trådlöst nätverk funkar inte, Zotac ION F-series+Ubuntu1
Jag blir nog tvungen att installera om datorn med windows 7 + xbmc imorgon, om inte någon kan hjälpa till, vilket jag antar skär i allas Ubuntu-hjärtan?


25 jun 2010, 09:40
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 13 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011