Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 19 sep 2019, 19:10



Svara på tråd  [ 7 inlägg ] 
 WIFI funkar inte????? 
Författare Meddelande

Blev medlem: 20 mar 2012, 10:39
Inlägg: 74
Ort: Granrisvägen 25A Örebro
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg WIFI funkar inte?????
Hej på er!
Har köpt en adapter till WIFI för min stationära dator.
Men den fungerar inte!!!!!
Det är en Netgear AC600 WiFi usb adapter.
Hittar inga driver till den på internet heller.
Vad gör man?


25 aug 2017, 11:13
Profil
Användarvisningsbild

Blev medlem: 06 dec 2014, 10:44
Inlägg: 890
OS: Linux Mint
Svara med citat
Inlägg Re: WIFI funkar inte?????
Prova...
Kod:
sudo apt-get install rtl8812au-dkms

http://www.humans-enabled.com/2016/03/h ... tgear.html

_________________
Alltid på kanelen!


25 aug 2017, 12:50
Profil

Blev medlem: 20 mar 2012, 10:39
Inlägg: 74
Ort: Granrisvägen 25A Örebro
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: WIFI funkar inte?????
Glömde tala om att jag kör LinuxMint 17.3 i den maskinen.
Det fungerar inte med dom kommandona.


25 aug 2017, 15:50
Profil
Användarvisningsbild

Blev medlem: 06 dec 2014, 10:44
Inlägg: 890
OS: Linux Mint
Svara med citat
Inlägg Re: WIFI funkar inte?????
I det här fallet är det ingen skillnad mellan ubuntu och linux mint. Fortsätt neråt i texten på länken, om det första kommandot inte fungerar.
Netgear har inget officiellt stöd för Linux på sina adaptrar, så det är möjligt att det inte fungerar alls, men alla länkar jag hittat, pekar på samma lösning som den jag länkar till.

_________________
Alltid på kanelen!


25 aug 2017, 16:30
Profil

Blev medlem: 20 mar 2012, 10:39
Inlägg: 74
Ort: Granrisvägen 25A Örebro
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: WIFI funkar inte?????
Det kör fast i terminalen i detta avsnitt:
lennart@lennart ~/wireless_driver/rtl8812au_rtl8821au $ make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/3.19.0-32-generic/build M=/home/lennart/wireless_driver/rtl8812au_rtl8821au modules
make[1]: Går till katalogen "/usr/src/linux-headers-3.19.0-32-generic"
CC [M] /home/lennart/wireless_driver/rtl8812au_rtl8821au/core/rtw_cmd.o
cc1: error: -Werror=incompatible-pointer-types: no option -Wincompatible-pointer-types
cc1: error: -Werror=date-time: no option -Wdate-time
make[2]: *** [/home/lennart/wireless_driver/rtl8812au_rtl8821au/core/rtw_cmd.o] Fel 1
make[1]: *** [_module_/home/lennart/wireless_driver/rtl8812au_rtl8821au] Fel 2
make[1]: Lämnar katalogen "/usr/src/linux-headers-3.19.0-32-generic"
make: *** [modules] Fel 2
lennart@lennart ~/wireless_driver/rtl8812au_rtl8821au $ sudo make install
sudo: kunde inte slå upp värddatorn lennart
install -p -m 644 8812au.ko /lib/modules/3.19.0-32-generic/kernel/drivers/net/wireless/
install: kan inte ta status på ”8812au.ko”: Filen eller katalogen finns inte
make: *** [install] Fel 1
lennart@lennart ~/wireless_driver/rtl8812au_rtl8821au $ sudo modprobe 8812au
sudo: kunde inte slå upp värddatorn lennart
modprobe: ERROR: could not insert '8812au': Invalid argument
lennart@lennart ~/wireless_driver/rtl8812au_rtl8821au $

Kommer inte längre.


25 aug 2017, 18:56
Profil
Användarvisningsbild

Blev medlem: 06 dec 2014, 10:44
Inlägg: 890
OS: Linux Mint
Svara med citat
Inlägg Re: WIFI funkar inte?????
Du verkar ha en väldigt gammal Linux-kärna. Kan du kolla det?
Kod:
uname -r

_________________
Alltid på kanelen!


25 aug 2017, 21:11
Profil
Användarvisningsbild

Blev medlem: 06 dec 2014, 10:44
Inlägg: 890
OS: Linux Mint
Svara med citat
Inlägg Re: WIFI funkar inte?????
Ok... med mer tid och en god natts sömn i bagaget, tror jag mig bättre förstå var felet ligger.
Det kanske inte är absolut nödvändigt, men jag tycker ändå att du skall uppgradera kärnan, om den inte redan är senast rekommenderad för din dist.
Kod:
sudo apt install linux-image-4.4.0-92-generic

...eller också kan du göra det via Uppdateringshanteraren/Visa/Linux-kärnor/4.4. Starta om datorn efter uppdateringen.


I Linux Mint 18.2 kan jag sedan installera de drivrutiner du behöver med följande kommandon...
Kod:
sudo apt update
sudo apt install linux-headers-generic build-essential git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd ~/rtl8812AU_8821AU_linux
make
sudo make install
sudo modprobe 8812au

Jag kan förstås inte testa om drivarna fungerar, eftersom jag inte har någon adapter, men installationen fungerade i alla fall felfritt.

_________________
Alltid på kanelen!


26 aug 2017, 08:31
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 7 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011