Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 15 jul 2020, 09:23



Svara på tråd  [ 7 inlägg ] 
 Fstab-mountar funkar inte 
Författare Meddelande
Användarvisningsbild

Blev medlem: 25 apr 2008, 00:18
Inlägg: 127
Ort: Malmö
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Fstab-mountar funkar inte
Hej,
Har kört kört Lucid sen andra alfan och tycker att det har funkar rätt bra. (Nu funkar ju till och med hibernate/suspend, :o )
Dock ett litet problem har jag stött på. Har ett par sambautdelningar i fstab, men av någon anledning monteras de inte vid boot utan man får köra en sudo mount -a varje gång man startat om datorn.
Detta funkade alldeles ypperligt innan jag uppgraderade till Lucid. Kör trådlöst om det har någon betydelse.
Är det någon som har någon idé om hur man kan fixa detta? Ett skript som monterar dom är ju kanske en (ful)lösning?
M v h Anders


13 apr 2010, 00:29
Profil WWW
Användarvisningsbild

Blev medlem: 06 apr 2008, 00:09
Inlägg: 5548
Ort: Göteborg/Mölndal/Falkenberg
OS: Ubuntu
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
Får du någon bra info med:
Kod:
grep -i error /var/log/samba/*

?

_________________
Agera genom att ta och behålla initiativet, ta de risker detta kräver...
http://www.enargo.com/it/
OpenVMS Shark - i Linux finns inte SYS$CMKRNL...


13 apr 2010, 07:45
Profil WWW
Användarvisningsbild

Blev medlem: 25 apr 2008, 00:18
Inlägg: 127
Ort: Malmö
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
/var/log/samba/log.wb-A-LAPTOP: write_data: write failure. Error = Broken pipe

vet inte hur det ska tolkas...


16 apr 2010, 01:02
Profil WWW
Användarvisningsbild

Blev medlem: 06 apr 2008, 00:09
Inlägg: 5548
Ort: Göteborg/Mölndal/Falkenberg
OS: Ubuntu
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
corneliusbrother skrev:
/var/log/samba/log.wb-A-LAPTOP: write_data: write failure. Error = Broken pipe

vet inte hur det ska tolkas...

Det innehåller egentligen inte så mycket information, i princip står det bara att den misslyckades med att skriva på grund av att förbindelesen var bruten.

Du har väl inte noauto satt i din fstab..?

Hur ser din fstab ut..?

_________________
Agera genom att ta och behålla initiativet, ta de risker detta kräver...
http://www.enargo.com/it/
OpenVMS Shark - i Linux finns inte SYS$CMKRNL...


16 apr 2010, 09:19
Profil WWW
Användarvisningsbild

Blev medlem: 25 apr 2008, 00:18
Inlägg: 127
Ort: Malmö
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
Den aktuella raden lyder:

//192.168.1.77/DISK\0402 /media/slug smbfs auto,user,uid=1000,gid=46,iocharset=$

Säkert något som är konstigt, men jag har haft det så sen 8.10 och det har funkat.


16 apr 2010, 21:28
Profil WWW
Användarvisningsbild

Blev medlem: 06 apr 2008, 00:09
Inlägg: 5548
Ort: Göteborg/Mölndal/Falkenberg
OS: Ubuntu
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
En skillnad mot mina monteringar är att jag kör med cifs istället för smbfs, men vad jag vet så har smbfs utgått och om det står kvar så tolkas det som cifs ändå. Sedan ser det lite konstigt ut med iocharset=$, jag vet inte riktigt vad resultatet blir av ett dollartecken där, själv har jag iocharset=utf8. Annars tycker jag att det ser rätt ok ut.

De samba-monteringar jag har själv ser ungefär snarlika ut i övrigt, förutom smådetaljer...

_________________
Agera genom att ta och behålla initiativet, ta de risker detta kräver...
http://www.enargo.com/it/
OpenVMS Shark - i Linux finns inte SYS$CMKRNL...


16 apr 2010, 21:40
Profil WWW
Användarvisningsbild

Blev medlem: 25 apr 2008, 00:18
Inlägg: 127
Ort: Malmö
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Fstab-mountar funkar inte
Tja, minns att jag hade lite problem med å ä ö i filnamnen, det kanske var då dollartecknet kom dit. Inga probs med det nu i a f.
Tänkte att problemet var att den försöker mounta innan nätverket är uppe.
Hur som helst ska jag byta ut smbfs mot cifs.


16 apr 2010, 22:07
Profil WWW
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 7 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011