Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 10 jul 2020, 01:29



Svara på tråd  [ 137 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5, 6, 7  Nästa
 Maverick Alfa 3 ute! 
Författare Meddelande

Blev medlem: 28 mar 2007, 23:01
Inlägg: 6212
Ort: Stockholm
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
xtr3m3 skrev:
Menar du den på det engelska forumet?
Japp, http://ubuntuforums.org/showthread.php?t=1549195

xtr3m3 skrev:
Har inte 1.9 installerat.
Visst har du det, version 1.9.0 RC 5.
xtr3m3 skrev:
X.Org X Server 1.8.99.905 (1.9.0 RC 5)


11 aug 2010, 16:09
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Bowmore skrev:
xtr3m3 skrev:
Menar du den på det engelska forumet?
Japp, http://ubuntuforums.org/showthread.php?t=1549195

xtr3m3 skrev:
Har inte 1.9 installerat.
Visst har du det, version 1.9.0 RC 5.
xtr3m3 skrev:
X.Org X Server 1.8.99.905 (1.9.0 RC 5)


Ok. Kollade säkert på fel sak i synaptic :)

_________________
Bild


11 aug 2010, 16:20
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
OK... läget med nVidias samt ATIs proprietära drivare är att de inte funkar, nVidias gäller enbart Ubuntus paket dvs nvidia-current.

Jag har inget behov eller önskemål att testa Nouveau-drivaren som jag bedömer som crap för närvarande.

Själv så kör jag då nVidias drivare nedladdad från nVidia.....kan inte själv aktivera Ubuntus nvidia drivare varken från arkivet eller xorg-edgers ppa.

Man laddar då ner drivaren härifrån:

http://www.nvnews.net/vbulletin/showthr ... ?p=2295223

Lägger den i roten på sitt /home/användare så slipper man senare terminalbläddrande.


Man måste sedan lägga in -ignoreABI för att drivaren ska laddas med Xorg 1.9.


Kod:
sudo gedit  /etc/X11/xorg.conf


Kod:
Section "ServerFlags"
Option "ignoreABI" "True"
EndSection


Sparar filen och startar om i Recovery, shift nedtryckt så får man upp menyn.

Väljer normal start i recoverymenyn som kommer upp.

Loggar in i terminalen.

Kod:
sudo sh NVIDIA*


Observera stjärnan efter NVIDIA så slippe6 rman skriva hela filnamnet, Installationen startar av drivaren.

Ctrl-Alt-Del när det är klart så startar burken om..... nu ska det funka !


EDIT
OBS!!!
Viktigt nu är att byts kärnan, mesa-paket eller vissa xorg-paket så MÅSTE drivaren installera igen..... bara att köra om i recovery !

-----------
Förövrigt så är det paketröra... jag har även ett trilskande gnome-shell som måste tas bort, annars fick jag på det mesta.


11 aug 2010, 17:44
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Tack för guiden :)

Tyvärr vill det inte åt mig då den gnäller om att nouveau används.
Försökte med att modproba det via nvidia-installationen men det gick inte.

Hur får jag bort nouveau? Finns en fil med det som är installerad. Bara det att den vill ta bort allt annat också om jag försöker ta bort den.

*EDIT*

Min xorg.conf fil är helt tom förutom det man skulle lägga till. Gör det nått?

_________________
Bild


Senast redigerad av xtr3m3 11 aug 2010, 18:26, redigerad totalt 1 gång.



11 aug 2010, 18:13
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
xtr3m3 skrev:
Tack för guiden :)

Tyvärr vill det inte åt mig då den gnäller om att nouveau används.
Försökte med att modproba det via nvidia-installationen men det gick inte.

Hur får jag bort nouveau? Finns en fil med det som är installerad. Bara det att den vill ta bort allt annat också om jag försöker ta bort den.


Jo det kan vara som så att man måste in i root-shell för att få till det.
Igår då jag strulade så fick jag det.

root-shell är då ett annat alternativ i recoverymenyn.

Man får då sedan cd'a sig till sitt eget home där drivaren ligger eftersom man kommer in i roots.

Det finns även andra sätt att blocka Nouveau men jag orkar inte leta rätt på det.... root-shell funkade för mig.

OBS att man då får en till varning i drivarinstallation och man svarar då nej att man inte vill avbryta.

Nu är vi då i den högre nörd-divisionen..... >:D kan iaf vara kul att prova... ;)


11 aug 2010, 18:25
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Ok. Kan ju i och för sig prova att installera nvidia-current och köra nvidia-xconfig. Då ändras xorg.conf filen. Kan lägga till texten också. Får se om jag får till det :)

_________________
Bild


11 aug 2010, 18:28
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
xtr3m3 skrev:
Ok. Kan ju i och för sig prova att installera nvidia-current och köra nvidia-xconfig. Då ändras xorg.conf filen. Kan lägga till texten också. Får se om jag får till det :)


Nej Ubuntus version, nvidia-current klarar inte alls xorg 1.9

Den från nVidia är en nyare version som då MÅSTE köras med ignoreABI.


11 aug 2010, 18:31
Profil

Blev medlem: 20 aug 2007, 07:11
Inlägg: 411
Ort: Slite, Gotland
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Tyvärr vägrar min dator att starta i recovery läge just nu. :P


11 aug 2010, 18:42
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
bjoost61 skrev:
Tyvärr vägrar min dator att starta i recovery läge just nu. :P


Jo men root-shell dvs det sista alternativet i recoverymenyn borde funka.

Sen får man bläddra via cd till sin drivare. cd .. cd .. cd home cd användare


11 aug 2010, 18:48
Profil
Användarvisningsbild

Blev medlem: 05 jan 2007, 22:26
Inlägg: 58
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Kanske dags att prova nu då när det kommit till alfa 3an,men men får se har så konfigurationer som skall över, aja det ger sig :p


11 aug 2010, 18:49
Profil WWW
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Vet inte om jag gjorde rätt men det funkade inte.
La till detta i xorg.conf:
Kod:
Section "ServerFlags"
Option "ignoreABI" "True"
EndSection


Men dum som jag var så tryckte jag på ja när den frågade om den skulle köra nvidia-xconfig och ställa in xorg.conf. Men jag gick in med nano i konsollen och la till det. La det högst upp om det nu spelar nån roll?
Startade om igen men ingenting.
Vad är det sista som du skrivit om kärnan?

_________________
Bild


11 aug 2010, 18:51
Profil

Blev medlem: 20 aug 2007, 07:11
Inlägg: 411
Ort: Slite, Gotland
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Jo "root shell" är säkert bra att försöka med. Men nu är det så att jag inte får igång recovery läget alls dvs. inga alternativ bara blinkande prompt.


11 aug 2010, 18:56
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
bjoost61 skrev:
Jo "root shell" är säkert bra att försöka med. Men nu är det så att jag inte får igång recovery läget alls dvs. inga alternativ bara blinkande prompt.


OK.... håll nere Shift hela tiden då datorn bootar så borde det hoppa fram.


11 aug 2010, 19:04
Profil

Blev medlem: 20 aug 2007, 07:11
Inlägg: 411
Ort: Slite, Gotland
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Jag får grub-listan med alternativ men den vägrar att starta i recovery-läget.


11 aug 2010, 19:14
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
bjoost61 skrev:
Jag får grub-listan med alternativ men den vägrar att starta i recovery-läget.


Jo då var det värre.....

Man kan editera bootsträngen i GRUB menyn och efter ett hastigt googlande så kanske nomodeset=0 funkar.

Diverse sökresultat
http://www.google.com/search?client=ubu ... 8&oe=utf-8

Okänt land även för mig....


11 aug 2010, 19:27
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Gjorde en helt ny xorg.conf, la in det som du skrivit och installerade om drivarna (hoppade över 32-bits libraries).
Vill ändå inte åt mig. När jag kör gksu nvidia-settings dyker detta upp:
Kod:
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.


Kör jag nvidia-xconfig så är det kört i nästa omstart. Vad gör jag för fel?
Måste jag ha nvidia-drivare installerade innan?

_________________
Bild


11 aug 2010, 19:47
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
xtr3m3 skrev:
Kör jag nvidia-xconfig så är det kört i nästa omstart. Vad gör jag för fel?
Måste jag ha nvidia-drivare installerade innan?


Problemet nu är det som "bjoost" skriver om att recovery verkar även det bryta ihop..... :P

Jag föreslår därför att du avvaktar ett tag.

Om man vill fördjupa sig ännu mer så kan man då även chroota en installation från en Live skiva eller annan fungerande installtion i en burk.

Så här gör man den enklaste formen av en chroot

Info som jag skrev en gång, enklaste formen.
http://ubuntu.se/t5339/

Via chrooten kan man då sedan göra vad man vill med en installation.

Som du ser så är vi nu mycket långt borta från normal användning men det kan ju vara kul ändå.....

Hursomhelst så riskerar man att hamna i ett chroot-läge..!!!


11 aug 2010, 19:56
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 05:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
Ok. Tror jag avvaktar. Vet hur det slutar om jag pillar för mycket ;D

_________________
Bild


11 aug 2010, 20:06
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 22:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
xtr3m3 skrev:
Ok. Tror jag avvaktar. Vet hur det slutar om jag pillar för mycket ;D


Hehe ;D

Jo men att hamna i ett chroot-läge med en utvecklingsversion är ingen katastrof...bara att bita i utmaningen... ;)

--------------------------------------------

Lyckades själv trassla mig ur en paketröra, cirkus 100 paket väntade.

Recovery-Root-shell funkade sedan för drivaren eftersom Mesa uppdaterades.

NM-managern kör nu med en ny version från NMs GIT.
https://lists.ubuntu.com/archives/maver ... 05440.html

Inga trubbel än så länge...

Mycket kul kväll.... ;D


11 aug 2010, 20:18
Profil

Blev medlem: 28 mar 2007, 23:01
Inlägg: 6212
Ort: Stockholm
OS: Ubuntu
Svara med citat
Inlägg Re: Maverick Alfa 3 ute!
pun skrev:
Lyckades själv trassla mig ur en paketröra, cirkus 100 paket väntade.
Hmm, paketröra är en överdrift. Pakethanteringen/beroenden för Maverick har fungerar över förväntan. Visst har det inträffat några hållningar (on holds) som man själv fått lösa upp manuellt men det är en del av spelet med att ligga i framkant. Själv sitter jag med en pre-alpha och har haft det (för) lugnt. De övriga problem du ev haft beror nog snarare på alla PPAer som du drar ner :P


11 aug 2010, 21:03
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 137 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5, 6, 7  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011