Ubuntu Sverige
https://ubuntu-se.org/phpBB3/

Problem med att installera "Mullvad"
https://ubuntu-se.org/phpBB3/viewtopic.php?f=208&t=61304
Sida 1 av 1

Författare:  skotersafari [ 30 dec 2018, 16:59 ]
Inläggsrubrik:  Problem med att installera "Mullvad"

Hej forumvänner!

Efter att ha tagit rygg i en annan Mullvadanvändares tråd bestämde jag mig för att detta är ett problem som förtjänar en egen tråd.

Jag har då laddat ner Mullvad enligt instruktionerna på deras hemsida. Efter att jag har laddat ner den så ligger alltså filen "MullvadVPN-2018.6_amd64.deb" i min "Hämtningar"-mapp. När jag klickar på filn öppnas "Programvara för ubuntu" men jag lyckas inte installera appen den vägen.

Så då har jag prövat via terminal (efter mullvads instruktioner på hemsidan) men inte lyckats. Är det något jag bara gör fel i terminal?

Min Terminal log:
"skotersafari@skotersafari-905S3G-906S3G-915S3G:~$ wget
https://mullvad.net/download/latest-deb-app
--2018-12-30 16:41:04-- https://mullvad.net/download/latest-deb-app
Slår upp mullvad.net (mullvad.net)... 46.166.138.241
Ansluter till mullvad.net (mullvad.net)|46.166.138.241|:443... ansluten.
HTTP-begäran skickad, väntar på svar... 302 Found
Adress: https://mullvad.net/media/app/MullvadVP ... _amd64.deb
[följer]
--2018-12-30 16:41:04--
https://mullvad.net/media/app/MullvadVP ... _amd64.deb
Återanvänder befintlig anslutning till mullvad.net:443.
HTTP-begäran skickad, väntar på svar... 200 OK
Längd: 52622728 (50M) [application/octet-stream]
Sparar till: "latest-deb-app.1"

latest-deb-app.1 100%[===================>] 50,18M 5,38MB/s om
9,4s

2018-12-30 16:41:13 (5,33 MB/s) - "latest-deb-app.1" sparades
[52622728/52622728]

skotersafari@skotersafari-905S3G-906S3G-915S3G:~$ sudo apt-get -y install gdebi-core &&
sudo gdebi MullvadVPN-2018.6_amd64.deb
[sudo] lösenord för skotersafari:
Läser paketlistor… Färdig
Bygger beroendeträd
Läser tillståndsinformation… Färdig
gdebi-core is already the newest version (0.9.5.7ubuntu1).
Du bör köra ”apt-get -f install” för att korrigera dessa:
Följande paket har beroenden som inte kan tillfredsställas:
libperl5.22 : Beroende av: perl-modules-5.22 (>= 5.22.1-9ubuntu0.6) men
5.22.1-9ubuntu0.5 kommer att installeras
perl : Beroende av: perl-modules-5.22 (>= 5.22.1-9ubuntu0.6) men
5.22.1-9ubuntu0.5 kommer att installeras
E: Otillfredsställda beroenden. Prova med ”apt-get -f install” utan
paket (eller ange en lösning).
skotersafari@skotersafari-905S3G-906S3G-915S3G:~$ sudo apt-get -f install gdebi-core &&
sudo gdebi MullvadVPN-2018.6_amd64.deb
Läser paketlistor… Färdig
Bygger beroendeträd
Läser tillståndsinformation… Färdig
gdebi-core is already the newest version (0.9.5.7ubuntu1).
Du bör köra ”apt-get -f install” för att korrigera dessa:
Följande paket har beroenden som inte kan tillfredsställas:
libperl5.22 : Beroende av: perl-modules-5.22 (>= 5.22.1-9ubuntu0.6) men
5.22.1-9ubuntu0.5 kommer att installeras
perl : Beroende av: perl-modules-5.22 (>= 5.22.1-9ubuntu0.6) men
5.22.1-9ubuntu0.5 kommer att installeras
E: Otillfredsställda beroenden. Prova med ”apt-get -f install” utan
paket (eller ange en lösning).
skotersafari@skotersafari-905S3G-906S3G-915S3G:~$ apt-get -f install
E: Kunde inte öppna låsfilen /var/lib/dpkg/lock-frontend - open (13:
Åtkomst nekas)
E: Unable to acquire the dpkg frontend lock
(/var/lib/dpkg/lock-frontend), are you root?
"


Jag har kontaktat Mullvads egna support, men ännu inte fått nå tillfredställande svar. Tänkte om det bara är något jag gör fel som nybörjar ubuntu-användare?

Tacksam för svar.

Författare:  webaake [ 30 dec 2018, 18:21 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

Jag ser att du har gdebi-core installerat och det borde betyda att du har Gdebi i nån av menyerna. GUI:t alltså. Med det är det lättare att installera hämtade deb-paket eftersom den tydligt visar om det blir nåt fel. Så starta gdebi och öppna ditt deb-paket med det.

Annars ser det bra ut (fast krångligare än det är)

Författare:  Gunnar Hjalmarsson [ 30 dec 2018, 18:34 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

Det verkar vara ett problem med paketsystemet som inte är relaterat till Mullvad.

Öppna Program & uppdateringar, välj fliken Uppdateringar, och tillse att såväl -security som -updates är ibockade. Kör sedan:

sudo apt update
sudo apt upgrade

Författare:  johanre [ 30 dec 2018, 19:19 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

Och om Gunnars tips inte räcker, kör även:

sudo apt-get -f install

Sent from my MI 6 using Tapatalk

Författare:  Broder Tuck [ 30 dec 2018, 20:01 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

Citat:
. . Efter att jag har laddat ner den så ligger alltså filen "MullvadVPN-2018.6_amd64.deb" i min "Hämtningar"-mapp. När jag klickar på filn öppnas "Programvara för ubuntu" men jag lyckas inte installera appen den vägen.
Prova med att dubbelklicka på .deb-filen.
Citat:
. . . Så då har jag prövat via terminal (efter mullvads instruktioner på hemsidan) men inte lyckats. Är det något jag bara gör fel i terminal?
Nej, du gör inget direkt fel.
När man använder sudo för ett kommando och anger sitt lösenord, så gäller inloggningen för/under en viss tid. Går det för lång tid mellan två kommandon som var för sig behöver sudo för sitt kommando, så måste sudo anges separat för respektive kommando. I din citerade text ser det ut som om det dröjde för länge efter första kommandot, när andra kommandot skrevs in. Här skulle även det ha börjat med sudo förmodligen.
Citat:
S3G-906S3G-915S3G:~$ sudo apt-get -f install gdebi-core &&
sudo gdebi MullvadVPN-2018.6_amd64.deb
. . . .
skotersafari@skotersafari-905S3G-906S3G-915S3G:~$ sudo apt-get -f

Därför får du frågan om du är root. . . .
Citat:
E: Unable to acquire the dpkg frontend lock
(/var/lib/dpkg/lock-frontend), are you root?
Min Terminal log:

skotersafari@-905S3G06S3G-915S3G:~$ sudo skotersafariapt-get -f install gdebi-core &&

Plus att du skulle ha haft ett mellanslag i skotersafariapt mellan orden skotersafari och apt-get....

Citat:
E: Kunde inte öppna låsfilen /var/lib/dpkg/lock-frontend - open (13:
Åtkomst nekas)
[/quote]Du har två systemprogram igång samtidigt. Stäng av det ena. Det kan vara två terminaler eller en terminal och ett Synapticprogram.

Allmänt tips inför att man tänker att installera nya program: kör alltid ett "sudo apt update" och "sudo apt upgrade" först.
Det kan hjälpa till med att undvika framtida problem med beroenden mellan program gamla och nyinstallerade program.

Lycka till! /tukken

Författare:  skotersafari [ 04 jan 2019, 18:27 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

Tack så mycket för hjälpen!

Efter att ha kört:
sudo apt update
sudo apt upgrade
sudo apt-get -f install

Gick det att installera appen via att dubbelklicka på .deb-filen. Tyvärr fungerade inte mullvad fast det blev installerat. Men efter att ha uppdaterat till Ubuntu 18.04.1 LTS fungerar det utmärkt!

Författare:  Broder Tuck [ 10 jan 2019, 13:33 ]
Inläggsrubrik:  Re: Problem med att installera "Mullvad"

:kram:
Härligt! Bra jobbat. /tukken

Sida 1 av 1 Alla tidsangivelser är UTC + 1 timme
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/