Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 17 okt 2019, 15:24



Svara på tråd  [ 8 inlägg ] 
 AutoKey slutar att fungera efter ett tag 
Författare Meddelande
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg AutoKey slutar att fungera efter ett tag
Råkar ut för ett problem ganska ofta när jag haft datorn igång ett tag, oftast några timmar eller så, men ibland betydligt tidigare än så.

Jag använder ett program som heter AutoKey som har blivit i stort sett oumbärligt med tiden. Vad programmet gör är att det känner av vad jag skriver och manipulerar det på ett sätt jag själv valt. Programmet är skrivet i Python, om nu det har någon betydelse, och jag använder det främst för ”autokorrigering”. Programmet byter helt enkelt ut vissa saker jag skrivit mot andra saker, exempelvis om jag skiver ”pss”, byts det omedelbart ut mot ”på så sätt” och så vidare. Nu kan man ju göra betydligt mer avancerade saker än så, men det spelar kanske ingen roll just i detta sammanhang.

Men ibland slutar programmet att fungera och man kan då kör det i debug-mode från en terminal. Programmet visar då vad det skickar och tar emot, och enligt programmet så får den inga svar från systemet (evdev, verkar det som).
Starta om Autokey hjälper i regel inte och inte heller att logga ut och sedan in igen. Oftast blir jag tvungen att starta om hela datorn, vilket tar en massa tid, framför allt med tanke på att jag måste stänga alla program och sedan öppna dem igen…

Så jag vill helt enkelt ha tips på vad man kan prova att starta om som kan ha med detta att göra. Det verkar som att AutoKey (eller något annat) får något i systemet att krascha eller ”hamna på undantag” på något sätt, så jag vill helt enkelt prova att starta om enskilda processer för att se om och när AutoKey börjar fungera igen, mest i felsökningssyfte.

Har givetvis ställt frågan till upphovsfolket bakom AutoKey, men de skiter väl fullständigt i att jag har problem, för ingen annan verkar ju ha det. Lite konstigt med tanke på att jag har samma problem på samtliga mina datorer, varav ingen är den andra lik förutom att alla har Ubuntu och AutoKey.

Hur som helst, om jag kommer på vad det är som kraschar kan jag ju alltid göra ett nytt försök att få AutoKey-folket att ta tag i problemet, men då krävs ju en del experimenterande och jag vet ju inte riktigt var jag ska börja, då jag är en riktig klåpare när det gäller datorer.

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


03 apr 2011, 13:18
Profil ICQ
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Hur startar jag om… vad då…?
Nu blev det allt för svårt här…! ;D

Eller så ställde jag frågan på fel ställe, vilket kanske är mer troligt. Ska leta runt lite efter ett bättre ställe att fråga på.

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


10 apr 2011, 11:00
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 22:28
Inlägg: 5919
Svara med citat
Inlägg Re: Hur startar jag om… vad då…?
Har du prova om det hjälper att starta om xservern?


10 apr 2011, 12:36
Profil

Blev medlem: 28 mar 2007, 23:01
Inlägg: 6212
Ort: Stockholm
OS: Ubuntu
Svara med citat
Inlägg Re: AutoKey slutar att fungera efter ett tag
Låter som att AutoKey har problem med gränssnittet mot evdev.

Har du testat att ställa om från evdev till xrecord?
Bör ligga i inställningarna under gränssnitt/interface

Se även buggen evdev deamon not useful on modern systems, causes problems


Ändrade trådtiteln till något mer beskrivande och flyttade tråden till Program


10 apr 2011, 13:31
Profil
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Hur startar jag om… vad då…?
Konservburk skrev:
Har du prova om det hjälper att starta om xservern?


Nej, det är inte så mycket jag har provat än så länge, förutom det uppenbara att starta om hela maskinen samt logga ut och sedan in igen.

Har också provat att köra AutoKey i debug-läge för att konstatera att AutoKey ser ut att göra det den ska, men att den inte får något svar.

Just nu fungerar AutoKey utmärkt, men jag ska testa när det händer igen nästa gång. Man vet aldrig när det blir; kanske om 3 sekunder, kanske nästa vecka…

Är det ”sudo /etc/init.d/gdm restart” som startar om x-servern?

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


10 apr 2011, 15:06
Profil ICQ
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: AutoKey slutar att fungera efter ett tag
Bowmore skrev:
Låter som att AutoKey har problem med gränssnittet mot evdev.

Har du testat att ställa om från evdev till xrecord?
Bör ligga i inställningarna under gränssnitt/interface

Se även buggen evdev deamon not useful on modern systems, causes problems


Ändrade trådtiteln till något mer beskrivande och flyttade tråden till Program


Ska testa även detta nästa gång det händer. Tror jag provat det tidigare men kommer inte ihåg resultatet…

Ska kolla länken också.

Tack för era svar.
:)

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


10 apr 2011, 15:08
Profil ICQ
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Hur startar jag om… vad då…?
Konservburk skrev:
Har du prova om det hjälper att starta om xservern?


Som nybörjare på pajasnivå så gjorde jag en /etc/init.d/gdm restart och det verkade ju vara samma sak som att logga ut och sedan in igen. Och inte fungerade AutoKey efter det heller, eller så hann det krascha innan jag hann testa…

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


19 apr 2011, 19:54
Profil ICQ
Användarvisningsbild

Blev medlem: 23 jun 2007, 16:18
Inlägg: 1256
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: AutoKey slutar att fungera efter ett tag  Tråden är löst
Rätt gammal tråd nu, men efter några uppdateringar av AutoKey har jag inte haft detta problem på länge nu. Det verkar ha löst sig själv, så att säga…

_________________
Vänliga hälsningar

Johnny Rosenberg
ジョニー・ローゼンバーグ

IEEE 1541 - binära prefix
ISO 8601 - datum och tid


01 sep 2012, 18:13
Profil ICQ
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 8 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011