Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 21 aug 2018, 06:18



Svara på tråd  [ 16 inlägg ] 
 Installera aktieanalysprogrammet QtStalker. 
Författare Meddelande

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Installera aktieanalysprogrammet QtStalker.
Hej igen! ;D

Jag försöker installera aktieanalysprogrammet QtStalker.
Men det tar emot. Jag har laddat ner en fil som heter; qtstalker_0.32-1_i386.deb

När jag nu dubbelklickar på filen så startas Programcentralen för ubuntu. Och då
står det; Beroendet tillfredsställs inte: libdb4.2
Och nu vet jag inte hur jag kommer vidare.

Nu har jag googlat runt och letat efter en "snitslad bana". Men det verkar vara
lite överkurs för min kompetensnivå; http://qtstalker.sourceforge.net/install.html

En annan sida jag ramlade över är denna;
https://tracker.debian.org/pkg/qtstalker
Är det något enklare att installera typ Ubuntu anpassat.


Är det någon som kan lotsa mig till en stabil installation?

Tacksam för hjälp.
Gubben i Kalmar


01 mar 2017, 14:27
Profil
Användarvisningsbild

Blev medlem: 27 mar 2006, 22:32
Inlägg: 3171
Ort: Stockholm / Tumba
OS: Ubuntu
Utgåva: 16.04 Xenial Xerus LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Gubben i Kalmar skrev:
. . . .
När jag nu dubbelklickar på filen så startas Programcentralen för ubuntu. Och då står det; Beroendet tillfredsställs inte: libdb4.2
Och nu vet jag inte hur jag kommer vidare.
Hej.. Med beroendeproblemet kan detta vara ett tips på att köra:

Först en uppdatering, så att du säkert är "i fas" med alla program.
Citat:
sudo apt update
Fixa till sådant som är påbörjat men inte färdigt
Citat:
sudo dpkg --configure -a
Gör färdigt påbörjade saker som avslutats pga olösta beroenden och försök lösa dem
Citat:
sudo apt -f install
Uppgradera paket med versionsberoenden till rätt version
Citat:
sudo apt dist-upgrade
Ignorera paket som inte går att installera pga beroenden
Citat:
sudo apt --fix-missing install
Repetera med detta kommando, för att återigen komma "i fas"
Citat:
sudo apt dist-upgrade
Rensa den lokala förteckningen över hämtade paket
Citat:
sudo apt-get clean
Rensa bort gamla paket som inte längre behövs
Citat:
sudo apt autoremove
Rensa cachen
Citat:
sudo apt-get clean
För säkerhets skull kan du även repetera kommandot
Citat:
sudo apt dist-upgrade
Ännu en koll på att uppdateringar är hämtade
Citat:
sudo apt update

Hoppas att detta hjälper dig. Lycka till! /tukken


01 mar 2017, 15:10
Profil
Användarvisningsbild

Blev medlem: 27 mar 2006, 22:32
Inlägg: 3171
Ort: Stockholm / Tumba
OS: Ubuntu
Utgåva: 16.04 Xenial Xerus LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Broder Tuck skrev:
Gubben i Kalmar skrev:
. . . .
När jag nu dubbelklickar på filen så startas Programcentralen för ubuntu. Och då står det; Beroendet tillfredsställs inte: libdb4.2
Och nu vet jag inte hur jag kommer vidare.
Hej.. Med beroendeproblemet kan detta vara ett tips på att köra:

Först en uppdatering, så att du säkert är "i fas" med alla program.
Citat:
sudo apt update
Fixa till sådant som är påbörjat men inte färdigt
Citat:
sudo dpkg --configure -a
Gör färdigt påbörjade saker som avslutats pga olösta beroenden och försök lösa dem
Citat:
sudo apt -f install
Uppgradera paket med versionsberoenden till rätt version
Citat:
sudo apt dist-upgrade
Ignorera paket som inte går att installera pga beroenden
Citat:
sudo apt --fix-missing install
Repetera med detta kommando, för att återigen komma "i fas"
Citat:
sudo apt dist-upgrade
Rensa den lokala förteckningen över hämtade paket
Citat:
sudo apt-get clean
Rensa bort gamla paket som inte längre behövs
Citat:
sudo apt autoremove
Rensa cachen
Citat:
sudo apt-get clean
För säkerhets skull kan du även repetera kommandot
Citat:
sudo apt dist-upgrade
Ännu en koll på att uppdateringar är hämtade
Citat:
sudo apt update

Hoppas att detta hjälper dig. Lycka till! /tukken

* Jag ser att det gamla kommandot "apt-get" i några fall har hängt med här, det räcker med enbart "apt".
Bra kommandon som jag läser, brukar jag skriva ner i en lista, den har växt under åren, men jag har inte redigerat den. Kör med apt du, så räcker det. /tukken


01 mar 2017, 16:05
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 13:49
Inlägg: 2489
Ort: Göteborg
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
QtStalker verkar vara ett gammalt program som inte underhålls. Har funnits i Ubuntu-förrådet (finns fortfarande i 12.04 ett par månader till).

Tveksamt om det är värt besväret att försöka installera programmet. Bygga det från källkoden är nog i så fall bästa sättet. (Men det är säkert inte heller okomplicerat.)


01 mar 2017, 16:23
Profil

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Tyvärr Tuck så får jag samma medlande som tidigare.

Jag läste i de olika installations beskrivningarna att "något" ska vara installerat innan man installerar QtSkalker. men vad de är och om de gäller installation på min burk med 14.10 vet jag inte.

Jag behöver ett par erfarna ögon som läser igenom länkarna och kan värdera innehåller, skilja agnarna från vetet.


01 mar 2017, 16:27
Profil

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Hej Gunnar.

Jo jag inser det Du skriver. Senaste anteckningen om support är från 2013.

Jag ger upp QtSkalker och går vidare på nästa objekt; Chart Geany.
Den är mer upp to date och kostar ca 3 pizzor.

Återkommer om jag kör fast.


01 mar 2017, 16:34
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 13:49
Inlägg: 2489
Ort: Göteborg
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Gubben i Kalmar skrev:
... min burk med 14.10 ...
14.10 är utan support sedan länge, och om det inte var ett 'tryckfel', bör du byta till en version som underhålls.


01 mar 2017, 16:51
Profil

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Förlåt, jag tittade igen, det är 14.04 LTS
Datorn är en HP, Intel® Core™ i3-2100 CPU @ 3.10GHz × 4

Vet inte om det blir någon skillnad.


01 mar 2017, 16:59
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 13:49
Inlägg: 2489
Ort: Göteborg
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Det är stor skillnad, eftersom 14.04 underhålls med säkerhetsuppdateringar tills 2019.


01 mar 2017, 17:06
Profil
Serveradmin
Användarvisningsbild

Blev medlem: 22 okt 2006, 09:13
Inlägg: 3599
Ort: Svedala
OS: Ubuntu
Utgåva: 17.04 Zesty Zapus
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Hhhmm, jag tiittade som hastigast på att installera qtstalker på min 16.04 maskin. Jag har inte lyckats helt än (hinner inte mer just nu) men har kommit så här långt:

Steg 1 (ladda ner källkod):
Kod:
cd /tmp
wget https://sourceforge.net/projects/qtstalker/files/qtstalker/qtstalker-0.36/qtstalker-0.36.tar.gz/download
mv download qtstalker.tgz


Steg 2 (packa upp källkodsarkivet):
Kod:
tar zxf qtstalker.tgz
cd qtstalker-0.36/


Steg 3 (installera beroenden och börja kompilera):
Kod:
johan@dor-lomin:/tmp/qtstalker-0.36$ sudo apt-get install qt4-default qt4-linguist-tools libqt4-dev libqt4-qt3support libqt4-network
johan@dor-lomin:/tmp/qtstalker-0.36$ ./configure --prefix=/usr/local
Building Makefile...
Done
Creating national language files in i18n...
Updating 'i18n/qtstalker_pl.ts'...
    Found 970 source text(s) (29 new and 941 already existing)
    Kept 27 obsolete entries
Done
Compiling existing translations...
Updating 'i18n/qtstalker_pl.qm'...
    Generated 0 translation(s) (0 finished and 0 unfinished)
    Ignored 970 untranslated source text(s)
Done
You may now 'make && make install'
johan@dor-lomin:/tmp/qtstalker-0.36$ make
cd lib/ && /usr/lib/x86_64-linux-gnu/qt4/bin/qmake /tmp/qtstalker-0.36/lib/lib.pro DEFINES\ +=\ QT_NO_COMPAT CONFIG\ +=\ qt -o Makefile
sh: 1: ta-lib-config: not found
cd lib/ && make -f Makefile
make[1]: Entering directory '/tmp/qtstalker-0.36/lib'
g++ -c -m64 -pipe -ffast-math -g -Wall -W -D_REENTRANT -fPIC -DQT_NO_COMPAT -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I/usr/local/include/ta-lib -I. -o QuotePlugin.o QuotePlugin.cpp
In file included from QuotePlugin.cpp:22:0:
QuotePlugin.h:26:30: fatal error: qnetworkprotocol.h: No such file or directory
compilation terminated.
Makefile:769: recipe for target 'QuotePlugin.o' failed
make[1]: *** [QuotePlugin.o] Error 1
make[1]: Leaving directory '/tmp/qtstalker-0.36/lib'
Makefile:45: recipe for target 'sub-lib-make_default' failed
make: *** [sub-lib-make_default] Error 2


02 mar 2017, 15:21
Profil WWW

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Tack johanre.

Jag är mycket intresserad av detta program............det finns mer avancerade alternativ typ ProRealTime mfl.
Men QtStalker har ribban där jag önskar, och kan köra den "reklamfri".

Om du lyckas få det att funka vore jag tacksam om du vill guida mig till en installation.

Jag håller tummarna!


02 mar 2017, 15:35
Profil

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
;D

Steg 1 och 2 har jag kört.

Det ser som jag kan se det bra ut.

Det ligger en massa filer i /tmp/qtstalker-0.36

Nu avvaktar jag Dina resultat.


02 mar 2017, 15:43
Profil
Serveradmin
Användarvisningsbild

Blev medlem: 22 okt 2006, 09:13
Inlägg: 3599
Ort: Svedala
OS: Ubuntu
Utgåva: 17.04 Zesty Zapus
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Har funderat lite... det finns ett antal sätt att angripa det här problemet:

1) Kompilera & bygga ett paket till Ubuntu 14.04 / 16.04 (sättet jag påbörjade tidigare idag)
2) Installera qtstalker i en docker instans av Ubuntu 12.04 på din Ubuntu 14.04 dator (ja, jag inser att du eventuellt inte riktigt förstår vad jag föreslår)
3) Installera en virtuell Ubuntu 12.04 dator i din Ubuntu 14.04 och kör qtstalker därifrån (ganska lik lösning #2)
4) Hitta ett sätt att konvertera Ubuntu 12.04 paketet till ett Ubuntu 14.04 paket - om det ens går.

Finns säkert några andra varianter, men poängen med alla dessa förslag är att de kräver lite jobb. Jag funderar just nu på vilken variant jag tycker kräver minst arbete för att nå fram till målet.


02 mar 2017, 23:03
Profil WWW

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
:)


Jag är med på ditt tänk johanre.

Det är som Du skriver, förslag 2 är lite kryptisk.
Men om man gör en anpassning till 14.04 och 16.04 tror jag förslag 1 är det mest användarvänliga. Enkel installation är högprioriterat (i mina ögon).
Jag har och kör JStock i min dator och Android platta. Men jag behöver veckovis/månatligt stämma av min "portfölj" från en grafisk framställning. Och det är här QtStalker kommer in i matchen.

Det finns andra "trading program", men då sitter man i knät på någon aktiemäklare som helt bestämmer villkoren för min "gratis licens".
Villkoren kan vara typ reklam, funktionalitet som mäklaren ändrar lite "nu o då". Mäklaren vill givet vis att man ska gå över till en "betalversion".

Det är lite tankar från min sida. Du får ta en funderare på vad som är lämpligt att göra. Ni har ju inte obegränsade resurser.

Vänligen
Gubben i Kalmar


03 mar 2017, 10:20
Profil
Serveradmin
Användarvisningsbild

Blev medlem: 22 okt 2006, 09:13
Inlägg: 3599
Ort: Svedala
OS: Ubuntu
Utgåva: 17.04 Zesty Zapus
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
Hoppsan! Jag har visst glömt svara här... Ber om ursäkt!

Jag lyckades kompilera programmet efter... "lite pill". Dock startar inte programmet även om det kompileras utan felmeddelande. Så just nu är jag lite villrådig...


15 mar 2017, 22:16
Profil WWW

Blev medlem: 17 jan 2014, 15:54
Inlägg: 137
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: Installera aktieanalysprogrammet QtStalker.
;D

Inen panik, tack för att Du tar av Din tid, johanre.

Har själv letat på webben efter alternativ. Men det mesta känns som "B-varianter" mot QtStalker. Tex att köra från Wine med Windows applikation.

Det är nog bara att gneta vidare. 8)


16 mar 2017, 08:14
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 16 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011