Ubuntu Sverige
https://ubuntu-se.org/phpBB3/

Enable Numlok
https://ubuntu-se.org/phpBB3/viewtopic.php?f=229&t=58801
Sida 1 av 1

Författare:  tommybe1 [ 02 apr 2014, 14:24 ]
Inläggsrubrik:  Enable Numlok

I äldre ubuntu kunde man installera Numlok. Då behövde man inte trycka på Numlok när man loggade in. Jag har försök installera installera Numlok både på 13.10 ock 14.04. När jag loggar in blir allt svart. Jag fick starta upp i recovery, där kunde jag ta bort filen jag skapade. /etc/lightdm/lightdm.conf
Det är inget större besvär att trycka på Numlok, men ibland glömmer man det.
Finns det ett annat sätt att starta Numlok från början.
Tacksam för svar

Författare:  Antec [ 03 apr 2014, 00:53 ]
Inläggsrubrik:  Re: Enable Numlok

Hej har du provat göra så här för att få numlock att vara aktiverat vid systemstart? https://help.ubuntu.com/community/NumLock

Författare:  webaake [ 03 apr 2014, 10:53 ]
Inläggsrubrik:  Re: Enable Numlok

Ett alternativ är numlockx.
Efter installation kan man autostarta det på flera sätt - från .xinitrc, eller från /etc/X11/Xsession.d/.

Exempel: i mappen /etc/X11/Xsession.d/ skapar man filen 55numlockx. I den skriver man in;
Kod:
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF


Att skriva i /etc/X11/Xsession.d/ kräver admin/root-behörighet.

Författare:  tommybe1 [ 05 apr 2014, 23:24 ]
Inläggsrubrik:  Re: Enable Numlok

Tack för era svar.
Tyvärr antec. Jag gjorde som det stod, men det hjälpte inte.

webaake Den filen fanns redan. Därför skrev jag ingenting.

55numlockx-filen ser ut så här:
# X session startup script: /etc/X11/Xsession.d/55numlockx

# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
case $NUMLOCK in
# 'keep' is an undocumented state (see `man 1 numlockx'), though
# /etc/default/numlockx mentions it; do nothing
keep)
return 0
;;
off|on|toggle)
;;
*)
NUMLOCK=on
ltd=/usr/sbin/laptop-detect
[ ! -x $ltd ] || ! $ltd || NUMLOCK=off
;;
esac
$nlx $NUMLOCK || :
}

# EOF

Författare:  webaake [ 06 apr 2014, 09:11 ]
Inläggsrubrik:  Re: Enable Numlok  Tråden är löst

Om du har numlockx installerat så testa
numlockx on &

I terminalen. Funkar det så är det bara att få det att autostarta nånstans ifrån. Det i sin tur beror på vilket DE du kör - googla!

Författare:  tommybe1 [ 09 apr 2014, 20:51 ]
Inläggsrubrik:  Re: Enable Numlok

Tack så mycket. Det gick bra. :D

Författare:  webaake [ 09 apr 2014, 21:18 ]
Inläggsrubrik:  Re: Enable Numlok

Gôtt!

Författare:  Nilleb [ 08 jul 2014, 10:08 ]
Inläggsrubrik:  Re: Enable Numlok

tommybe1 skrev:
Tack så mycket. Det gick bra. :D


Du får gärna berätta mer utförligt hur, terminalkommandon.... :D

PS
Det verkar som design slynglana (för att prata med Påvel ;) eller vilka det nu är hittar nya sätt att dj...las med oss som använder rekommendationen att ha både siffror och andra tecken i våra lösen ord vid varje ny dist >:D
Eller jobbar dom för att succesivt återinföra teleprinter o hålkort ???
DS

Mannen med käpphästen: numlock on redan vid installation p.s.s. som val av språk o tangentbord.

Författare:  Nilleb [ 11 jul 2014, 07:55 ]
Inläggsrubrik:  Re: Enable Numlok

Antec skrev:
Hej har du provat göra så här för att få numlock att vara aktiverat vid systemstart? https://help.ubuntu.com/community/NumLock


Även jag har testat tipset för Lightdm. =>
Numlock på i inloggnings skärmen.
Inloggning =>
Numlock av ???

Författare:  Nilleb [ 11 jul 2014, 08:30 ]
Inläggsrubrik:  Re: Enable Numlok

webaake skrev:
Ett alternativ är numlockx.
Efter installation kan man autostarta det på flera sätt - från .xinitrc, eller från /etc/X11/Xsession.d/.

Exempel: i mappen /etc/X11/Xsession.d/ skapar man filen 55numlockx. I den skriver man in;
Kod:
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF


Att skriva i /etc/X11/Xsession.d/ kräver admin/root-behörighet.


Min 55numlock, med Webaake's tips:

# X session startup script: /etc/X11/Xsession.d/55numlockx

# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
case $NUMLOCK in
# 'keep' is an undocumented state (see `man 1 numlockx'), though
# /etc/default/numlockx mentions it; do nothing
keep)
return 0
;;
off|on|toggle)
;;
*)
NUMLOCK=on
ltd=/usr/sbin/laptop-detect
[ ! -x $ltd ] || ! $ltd || NUMLOCK=off
;;
esac
$nlx $NUMLOCK || :
}

# Webaake's tips 140703
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF

EOF

=>
numlock på i inloggningsskärm.
inloggn => numlock blinkar till men förblir på ;D

Men går det att kommentera bort original raderna med numlock rappakaljan ???

Sätter min egen tråd Numlock ..... igen igen igen, som löst med hänvisning hit.

Edit:
Nu for den lede i mig och jag kommenterade bort original numlock rappakaljan.
Och se numlock blinkar inte längre till och förblir på 8)

Min hypotes är att de raderna har lagts till av en MS infiltratör ;D

Sida 1 av 1 Alla tidsangivelser är UTC + 1 timme [ Sommartid ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/