Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 30 mar 2020, 16:10



Svara på tråd  [ 7 inlägg ] 
 Problem uppdatera Lubuntu 16.04.3 
Författare Meddelande

Blev medlem: 28 dec 2017, 18:34
Inlägg: 15
OS: Lubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Problem uppdatera Lubuntu 16.04.3  Tråden är löst
Hej

Har precis installerat Lubuntu 16.04.3 på en IBM tp 42. Är ingen större fena på linux men installationen gick fint som det verkade. Dock har systemet problem att uppdatera; när jag kört programuppdateraren får jag detta meddelande:

Paketsystemet är trasigt

Kontrollera om du använder tredjepartsförråd. Inaktivera dem i så fall eftersom de är en vanlig problemkälla.
Kör även följande kommando i en terminal: apt-get install -f


Har följt dom råden och får i terminalen detta svar:

Läser paketlistor… Färdig
Bygger beroendeträd
Läser tillståndsinformation… Färdig
Korrigerar beroenden… Färdig
Följande paket har installerats automatiskt och är inte längre nödvändigt:
linux-headers-generic-hwe-16.04
Använd ”sudo apt autoremove” för att ta bort det.
The following additional packages will be installed:
linux-image-4.10.0-42-generic
Föreslagna paket:
fdutils linux-tools
Följande NYA paket kommer att installeras:
linux-image-4.10.0-42-generic
0 att uppgradera, 1 att nyinstallera, 0 att ta bort och 0 att inte uppgradera.
1 är inte helt installerade eller borttagna.
E: Kunde inte erhålla låset /var/cache/apt/archives/lock - open (11: Resursen tillfälligt otillgänglig)
E: Kunde inte låsa katalogen /var/cache/apt/archives/


I synaptic så hittas en trasigt paket: linux-image-extra-4.10.0-42-generic. Försökt att ominstallera detta men får då till svar: E: Internal Error, No file name for linux-image-extra-4.10.0-42-generic:i386

Tacksam för hjälp!


28 dec 2017, 18:49
Profil

Blev medlem: 28 dec 2017, 18:34
Inlägg: 15
OS: Lubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
Testade sudo apt-get install -f igen och fick då ett annat svar:

Läser paketlistor… Färdig
Bygger beroendeträd
Läser tillståndsinformation… Färdig
Korrigerar beroenden… Färdig
Följande paket har installerats automatiskt och är inte längre nödvändigt:
linux-headers-generic-hwe-16.04
Använd ”sudo apt autoremove” för att ta bort det.
The following additional packages will be installed:
linux-image-4.10.0-42-generic
Föreslagna paket:
fdutils linux-tools
Följande NYA paket kommer att installeras:
linux-image-4.10.0-42-generic
0 att uppgradera, 1 att nyinstallera, 0 att ta bort och 0 att inte uppgradera.
1 är inte helt installerade eller borttagna.
Behöver hämta 0 B/18,7 MB arkiv.
Efter denna åtgärd kommer ytterligare 49,8 MB utrymme användas på disken.
Vill du fortsätta? [J/n] j
(Läser databasen ... 153559 filer och kataloger installerade.)
Förbereder att packa upp .../linux-image-4.10.0-42-generic_4.10.0-42.46~16.04.1_i386.deb ...
This kernel does not support a non-PAE CPU.
dpkg: fel vid hantering av arkivet /var/cache/apt/archives/linux-image-4.10.0-42-generic_4.10.0-42.46~16.04.1_i386.deb (--unpack):
underprocessen nytt pre-installation-skript gav felkod 1
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.10.0-42-generic /boot/vmlinuz-4.10.0-42-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.10.0-42-generic /boot/vmlinuz-4.10.0-42-generic
Fel uppstod vid hantering:
/var/cache/apt/archives/linux-image-4.10.0-42-generic_4.10.0-42.46~16.04.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Står ju något om att non PAE inte stöds, någon ledtråd i det hela. Fick ju köra force pae för att kunna installera.


28 dec 2017, 19:08
Profil

Blev medlem: 28 dec 2017, 18:34
Inlägg: 15
OS: Lubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
Hittade felet. Var just forcepae som strulade (ska läsa terminaltexterna bättre framöver :-)
För den som har liknande problem:
[url]
https://askubuntu.com/questions/463440/ ... s-kernel-d[/url]

Fick också använda xedit istället för gedit för att kunna redigera i grub-filen.


28 dec 2017, 19:42
Profil
Användarvisningsbild

Blev medlem: 25 jan 2007, 04:15
Inlägg: 16469
Ort: $HOME
OS: Gentoo
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
Välkommen! Vad bra att det löste sig. :) Markera gärna tråden som löst genom att klicka på bocken upp till höger.

_________________
Linuxkompis - En vänlig Linux-gemenskap för alla!


28 dec 2017, 20:26
Profil WWW
Användarvisningsbild

Blev medlem: 27 mar 2006, 22:32
Inlägg: 3330
Ort: Stockholm / Tumba
OS: Linux Mint
Utgåva: 16.04 Xenial Xerus LTS
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
;)
Jag säger också Välkommen till oss.
Samtidigt erkänner jag att du verkar väldigt van vid Linux och terminalen. Jag gissar att du har hållit på ett tag med några motsvarande operativ, eftersom du hade förmåga att reda upp problemen genom att söka och finna utvägar.

Det tog mig själv lång tid (antal år) innan jag var hjälpligt självgående i olika felhanteringar. Är inte riktigt framme än, vid alla fel som faller över mig.
( Ca tolv år senare 8) ) :-[

Som sagt, Välkommen!
/tukken

_________________
Ubuntu med både Gnome och Mate. Kör mestadels med LinuxMint Cinnamon till vardags. Våren 2019.


28 dec 2017, 21:09
Profil

Blev medlem: 28 dec 2017, 18:34
Inlägg: 15
OS: Lubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
Tack, roligt att vara här. Har kört debian några år men var problem att uppdatera det så därför bytte jag nu till lubuntu så hade hoppats att det skulle fungera utan besvär... men blev ju bra till slut. Har egentligen ingen aning om vad jag gör men hittar men en tråd som beskriver rätt problem så brukar det lösa sig bra.
Hittar dock inte hur jag markerar tråden som löst så ni får gärna beskriva det :-)


31 dec 2017, 16:09
Profil
Användarvisningsbild

Blev medlem: 25 jan 2007, 04:15
Inlägg: 16469
Ort: $HOME
OS: Gentoo
Svara med citat
Inlägg Re: Problem uppdatera Lubuntu 16.04.3
ZuneZ skrev:
Tack, roligt att vara här. Har kört debian några år men var problem att uppdatera det så därför bytte jag nu till lubuntu så hade hoppats att det skulle fungera utan besvär... men blev ju bra till slut. Har egentligen ingen aning om vad jag gör men hittar men en tråd som beskriver rätt problem så brukar det lösa sig bra.
Hittar dock inte hur jag markerar tråden som löst så ni får gärna beskriva det :-)


Uppe i det högra hörnet vid det första inlägget ska det finnas en grön bock. :)

_________________
Linuxkompis - En vänlig Linux-gemenskap för alla!


31 dec 2017, 23:01
Profil WWW
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 7 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 2 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011