Ubuntu Sverige
https://ubuntu-se.org/phpBB3/

PoEdit Error!!
https://ubuntu-se.org/phpBB3/viewtopic.php?f=34&t=59613
Sida 1 av 1

Författare:  skalman65 [ 31 mar 2015, 22:04 ]
Inläggsrubrik:  PoEdit Error!!

Har fått följande felmedelande när jag sparar det jag har översatt.

Problemet kom bara mitt i översättningen, samt att det är bara den översättningen som ger felmedelandet.

Någon som har någon tanke på vad som kan ha hänt i översättningen?

Författare:  gusnan [ 01 apr 2015, 00:11 ]
Inläggsrubrik:  Re: PoEdit Error!!

I första raden i meddelandet ser det ut som om filen sparades korrekt (Även om formatteringen kanske inte är riktigt som den ska).

Du kan testa att köra
Kod:
msgfmt --check [filen]
i en terminal på den aktuella po-filen, vilket kan ge dig mer information om du har tur.

Programmet msgfmt finns i gettext-paketet och det bör du redan ha installerat, eftersom poedit är beroende av det.

Annars, vilken version av poedit är det du använder?

Författare:  skalman65 [ 01 apr 2015, 20:54 ]
Inläggsrubrik:  Re: PoEdit Error!!

Prövade att köra koden du tipsade om, vilket gav mig ett felmedelande att
"filen inte fanns"
Vilket inte var så konstigt då jag hade döpt program mappen "lightsoff" till det svenska namnet
"släck lyset" med ett mellan slag.

Då jag ändrade detta till det engelska där det inte är något mellan slag
och körde koden på nytt så fick jag bara en ny grundrad inge felmedelande eller så,
om det innebar att det inte fann några fel eller jag gjorde något galet, vet jag inte.
men feletmedelandet försvann och det fungerar bra nu.


Tackar för hjälpen, lite lustigt att jag kunde översätta hälften innan det vart problem.

Poedit versionen jag använder är 1.5.4

Författare:  morpa [ 01 apr 2015, 21:44 ]
Inläggsrubrik:  Re: PoEdit Error!!

Jag har också det där felet för samma version av Poedit - den versionen är tyvärr den senaste som verkar finnas för Ubuntu, och den är riktigt gammal.

Frågade om det på forumet för poedit och fick bara svaret att uppgradera. Finns dock ingen färdigkompilerad binär för Linux för nyare versioner, och jag fick inte alla beroenden att fungera för kompilering på Ubuntu 14.10.

MEN - trots att jag får felmeddelandet så sparas filen och ändringar jag gjort i den. Så det är användbart - Kolla om detsamma gäller för dig..

Författare:  skalman65 [ 02 apr 2015, 19:36 ]
Inläggsrubrik:  Re: PoEdit Error!!

problemet och felmedelandet försvann sedan för mig när jag bytte till ett namn utan mellanslag på arbetsmapen för -po filen.

Författare:  morpa [ 02 apr 2015, 20:49 ]
Inläggsrubrik:  Re: PoEdit Error!!

skalman65 skrev:
problemet och felmedelandet försvann sedan för mig när jag bytte till ett namn utan mellanslag på arbetsmapen för -po filen.


Aha, ska kolla här med om det är mappnamnen som ställer till det.

Författare:  gruble [ 02 apr 2015, 21:22 ]
Inläggsrubrik:  Re: PoEdit Error!!

morpa skrev:
skalman65 skrev:
problemet och felmedelandet försvann sedan för mig när jag bytte till ett namn utan mellanslag på arbetsmapen för -po filen.


Aha, ska kolla här med om det är mappnamnen som ställer till det.

Jag är använder aldrig mellanslag eller åäö i mapp namn. Mellanslaget i mappar blir av gammal vana ett understreck _

Författare:  Meerkat [ 26 jun 2016, 11:59 ]
Inläggsrubrik:  Re: PoEdit Error!!

Jag hade samma problem. Tog bort åäö i sökvägen och problemet försvann.

Sida 1 av 1 Alla tidsangivelser är UTC + 1 timme [ Sommartid ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/