Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 27 jun 2019, 10:29

Kategoriregler


Varning! Det som diskuteras här är inte alltid enkelt och det kan hända att vissa installationer/modifieringar kan göra ditt system oanvändbart. Inget för nybörjare. Gör alltid backup av känslig data innan du experimenterar.



Svara på tråd  [ 64 inlägg ]  Gå till sida 1, 2, 3, 4  Nästa
 Despotify kräver inte att man pröjsar [Delad /mod] 
Författare Meddelande
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Despotify kräver inte att man pröjsar [Delad /mod]
@ Rasmus; Nej, despotify kräver inte att man pröjsar. ;)

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


01 jul 2009, 21:05
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Det råder menings skiljaktigheter om det
Citat:
February 26th, 2009 - Update regarding the usage of 'Free' accounts

Despotify has been blocked for users using 'Free' accounts.
You can still use Despotify using 'Premium' accounts.

We will not attempt to circumvent this block, nor accept any patches circumventing it. If you disagree with this decision, you are free to fork the code.


01 jul 2009, 21:19
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Nja.
Citat:
We will not attempt to circumvent this block, nor accept any patches circumventing it. If you disagree with this decision, you are free to fork the code.

Kan dock meddela att det fungerar alldeles utmärkt. :)

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


01 jul 2009, 21:20
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
dmz skrev:
Nja.
Citat:
We will not attempt to circumvent this block, nor accept any patches circumventing it. If you disagree with this decision, you are free to fork the code.

Kan dock meddela att det fungerar alldeles utmärkt. :)

:o
Kod:
rasmus@pajn-debian:/$ svn co https://despotify.svn.sourceforge.net/svnroot/despotify despotify 
svn: OPTIONS till 'https://despotify.svn.sourceforge.net/svnroot/despotify': kunde inte ansluta till server (https://despotify.svn.sourceforge.net)
:'(

Fast nu börjar vi kanske gå lite off-topic?


01 jul 2009, 21:25
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Du behöver Rev. 291.
Jodå, men jag är säker på att mod kan knåpa av detta till en egen tråd. :)

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


01 jul 2009, 21:35
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Okej, då fortsätter jag och hoppas att någon mod delar tråden :)

Jag tankade tarbollen istället, den är nu installerad. Hur får jag igång det?
Måste jag ha despotifyklienten (den ville inte byggas)?

EDIT:
Lite utdata
Kod:
rasmus@pajn-debian:~/despotify/src$ make
make -s -C lib -f local.mk
make -s -C clients/simple -f local.mk
make -s -C clients/despotify -f local.mk
CC commands.c
In file included from commands.c:11:
ui.h:53: error: expected ‘)’ before ‘_Bool’
ui.h:66: error: expected specifier-qualifier-list before ‘ui_keypress_cb_t’
ui.h:82: error: expected ‘)’ before ‘ch’
In file included from commands.c:12:
ui_footer.h:22: error: expected ‘)’ before ‘ch’
In file included from commands.c:13:
ui_log.h:13: error: expected ‘)’ before ‘ch’
make[1]: *** [commands.o] Fel 1
make: *** [clients/despotify] Fel 2
rasmus@pajn-debian:~/despotify/src$


01 jul 2009, 21:40
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Editera lib/session.c;

Kod:
session->client_revision = 44764;

till;
Kod:
session->client_revision = 99999;


Och kompilera. Notera att du ska ha revision 291, ingenting annat.

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


01 jul 2009, 21:42
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Hur får jag tag på den?
Här är det lite för höga nummer:
http://despotify.svn.sourceforge.net/src/

EDIT: I min "höga" rev. är det där redan fixat. Men den duger alltså inte?


Senast redigerad av Rasmus 01 jul 2009, 21:46, redigerad totalt 1 gång.



01 jul 2009, 21:44
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Rasmus skrev:
Hur får jag tag på den?
Här är det lite för höga nummer:
http://despotify.svn.sourceforge.net/src/

EDIT: I min "höga" rev. är det där redan fixat. Men den duger alltså inte?



http://despotify.svn.sourceforge.net/vi ... vision=291

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


01 jul 2009, 21:47
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 09:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 19.04 Disco Dingo
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
@Rasmus: pröva

svn checkout --revision 291 .............................


@dmz: tack för tipset!

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


01 jul 2009, 21:55
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
@webaake funkade inte, samma fel som tidigare vid svn försök.
föresten, kan du inte dela desoptify-delen och stoppa in den i en egen tråd?

Jag kopierade dem fem filerna som skiljde sig manuellt och ner jag nu försöker kompliera får jag
Kod:
rasmus@pajn-debian:~/despotify/src$ make
make -s -C lib -f local.mk
Generating dependencies
CC auth.c
CC commands.c
CC handlers.c
CC keyexchange.c
CC packet.c
CC puzzle.c
CC session.c
CC despotify.c
despotify.c: In function ‘despotify_init_client’:
despotify.c:61: error: number of arguments doesn’t match prototype
despotify.h:172: error: prototype declaration
despotify.c: At top level:
despotify.c:348: error: conflicting types for ‘despotify_play’
despotify.h:229: error: previous declaration of ‘despotify_play’ was here
despotify.c:569: error: conflicting types for ‘despotify_search’
despotify.h:209: error: previous declaration of ‘despotify_search’ was here
despotify.c: In function ‘despotify_search’:
despotify.c:600: error: ‘struct playlist’ has no member named ‘search’
despotify.c:601: warning: implicit declaration of function ‘xml_parse_searchlist’
despotify.c: At top level:
despotify.c:617: error: conflicting types for ‘despotify_search_more’
despotify.h:211: error: previous declaration of ‘despotify_search_more’ was here
despotify.c: In function ‘despotify_search_more’:
despotify.c:620: error: ‘struct playlist’ has no member named ‘search’
despotify.c:623: error: ‘struct playlist’ has no member named ‘search’
despotify.c:628: error: ‘struct playlist’ has no member named ‘search’
despotify.c: At top level:
despotify.c:750: error: conflicting types for ‘despotify_get_playlist’
despotify.h:218: error: previous declaration of ‘despotify_get_playlist’ was here
despotify.c: In function ‘despotify_free_playlist’:
despotify.c:811: error: ‘struct playlist’ has no member named ‘search’
despotify.c: At top level:
despotify.c:954: error: conflicting types for ‘despotify_get_artist’
despotify.h:192: error: previous declaration of ‘despotify_get_artist’ was here
despotify.c: In function ‘despotify_get_artist’:
despotify.c:958: error: ‘struct despotify_session’ has no member named ‘artist’
despotify.c:979: warning: implicit declaration of function ‘xml_parse_artist’
despotify.c:979: error: ‘struct despotify_session’ has no member named ‘artist’
despotify.c:984: error: ‘struct despotify_session’ has no member named ‘artist’
despotify.c:985: warning: control reaches end of non-void function
despotify.c: At top level:
despotify.c:1020: error: conflicting types for ‘despotify_get_album’
despotify.h:194: error: previous declaration of ‘despotify_get_album’ was here
despotify.c: In function ‘despotify_get_album’:
despotify.c:1024: error: ‘struct despotify_session’ has no member named ‘album’
despotify.c:1045: warning: implicit declaration of function ‘xml_parse_album’
despotify.c:1045: error: ‘struct despotify_session’ has no member named ‘album’
despotify.c:1050: error: ‘struct despotify_session’ has no member named ‘album’
despotify.c:1051: warning: control reaches end of non-void function
make[1]: *** [despotify.lo] Fel 1
make: *** [lib] Fel 2


01 jul 2009, 22:00
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 09:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 19.04 Disco Dingo
Svara med citat
Inlägg Re: Trött på slim? Installera Qingy!
Har försökt att dela tråden men ni har blandat i inläggen, så det får vara. Detta är ju Experimentverkstan, så....

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


02 jul 2009, 06:28
Profil
Användarvisningsbild

Blev medlem: 07 apr 2007, 22:28
Inlägg: 5919
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
webaake skrev:
Har försökt att dela tråden men ni har blandat i inläggen, så det får vara. Detta är ju Experimentverkstan, så....

Då delar jag istället efter bästa förmåga. Orginaltråden finns återfinns här: viewtopic.php?t=41176


02 jul 2009, 07:29
Profil
Användarvisningsbild

Blev medlem: 11 dec 2006, 03:31
Inlägg: 465
Ort: Mariestad
OS: Arch Linux
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Rasmus, fick du igång det?

_________________
http://p1i-tips.blogspot.com/
http://twitter.com/spacecube
http://www.openstreetmap.org/user/spacecube_40


03 jul 2009, 02:05
Profil WWW
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
@ Rasmus; [...] som skilde sig? Har du alla dependencies som behövs installerat?

@ whac; IRC?

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


03 jul 2009, 04:35
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Okej, vi tar det från början.
Kod:
svn checkout --revision 291 https://despotify.svn.sourceforge.net/svnroot/despotify despotify

sen installerar jag beroendena på deras sida (den översta och den tredje för GStreamer backend)
komplierar och intsallerar. Inga problem. Men nu när den är installerad, hur startar jag klienten?
Det känns som han bara installerar klienten "simple" och "gateway". Hur gör jag för att få den att installera "despotify"?

I nyaste rev kunde man ställa in det i filen Makefile.local.mk men det verkar inte gå här?


Kod:
LD libdespotify.la
make -s -C clients/simple -f local.mk
Generating dependencies
LD simple
make -s -C clients/gateway -f local.mk
Generating dependencies


EDIT:
Om jag startar klienten "simple" får jag medelandet
Kod:
=================================================
                  N O T I C E
       You do not have a premium account.
  Playback and playlists will not be available.
=================================================

Sen går jag in i en lista
Kod:
list 4

När jag går in i listan postar den hela listan så så långt är det lungt, men när jag försöker spela så händer det inget
Kod:
> play  58

>


EDIT2:
Jag sitter på ett nyinstallerat os eftersom debian krånglade, därför hade jag inte konfat ljudet än. Nu när jag gjorde det så vad var det inte jag hörde i högtalaren om inte låt 58 ;D
Nu vill jag bara få igång den "riktiga" despotify klienten.


03 jul 2009, 09:44
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Ja, att det där meddelandet dyker upp spelar ingen roll då det som du nu märkt går utmärkt ändå.

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


03 jul 2009, 09:58
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Despotify klienten var utkommenterad i Makefile, när jag tar bort # och försöker bygga igen går det år skogen.
Kod:
ubuntu@ubuntu:~/despotify/src$ make
make -s -C lib -f local.mk
make -s -C clients/despotify -f local.mk
Generating dependencies
In file included from despotify.c:28:
ui-playlist.h:12:22: error: playlist.h: No such file or directory
ui-core.c:18:22: error: playlist.h: No such file or directory
ui-player.c:15:22: error: playlist.h: No such file or directory
ui-playlist.c:18:22: error: playlist.h: No such file or directory
ui-search.c:14:22: error: playlist.h: No such file or directory
CC ADMclubbing.c
ADMclubbing.c: In function ‘ADMclubbing’:
ADMclubbing.c:84: warning: format not a string literal and no format arguments
CC despotify.c
despotify.c:11:21: error: ncurses.h: No such file or directory
In file included from despotify.c:27:
ui-player.h:9:20: error: curses.h: No such file or directory
In file included from despotify.c:28:
ui-playlist.h:12:22: error: playlist.h: No such file or directory
In file included from despotify.c:28:
ui-playlist.h:14: error: expected ‘)’ before ‘*’ token
ui-playlist.h:15: error: expected ‘)’ before ‘*’ token
make[1]: *** [despotify.o] Error 1
make: *** [clients/despotify] Error 2


03 jul 2009, 10:03
Profil
Användarvisningsbild

Blev medlem: 29 jul 2008, 19:42
Inlägg: 3292
OS: Arch Linux
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Nöjer du dig inte med simple-klienten?

src/bindings, se om du kan kompilera ruby-bindings

Är inte helt lätt att försöka göra samma sak som du då det tyvärr kräver gstreamer/pulseaudio, vilket jag aldrig tänker dra in här. Övriga klienter bygger fint dock, och despotfy-klienten klagar på

ui-playlist.h:12:22: error: playlist.h: No such file or directory
./bindings/ruby/ext/playlist.h

_________________
ǁ A: Because it obfuscates the reading.
ǁ Q: Why is top posting so bad?


Senast redigerad av dmz 03 jul 2009, 10:12, redigerad totalt 1 gång.



03 jul 2009, 10:06
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Despotify kräver inte att man pröjsar [Delad /mod]
Jo, förutom att man måste skriva lösenordet öppet direkt i terminelen.

Okej :-\

Man får koda en egen klient som även har stöd att spela upp musik man har på hårddisken. Bygga in (de)spotify stöd i mocp tex :P

Stort tack! Skönt att slippa wine och om man räknar bort musiken så får man en helt fri dator :D


03 jul 2009, 10:11
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 64 inlägg ]  Gå till sida 1, 2, 3, 4  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011