Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 31 maj 2020, 22:41



Svara på tråd  [ 5 inlägg ] 
 Cisco-router (IOS) & DNS 
Författare Meddelande
Användarvisningsbild

Blev medlem: 30 jan 2007, 15:59
Inlägg: 1258
Ort: Kristianstad/Sverige
OS: Fedora
Svara med citat
Inlägg Cisco-router (IOS) & DNS
Hej!

Jag har tillfälligt fått låna en Cisco 2811 router att leka med.
Jag har lyckats sätta up den så att dne funkar ungefär som min vanliga router, dvs får en extern adress via DHCP och sedan själv är DHCP för det interna nätverket + agerar NAT.
I DHCP-inställningarna för det interna nätverket så ska man ange DNS-servrar. Mitt problem är att dessa tilldelas jag ju via DHCP på det externa interfacet, och det blir därför lite svårt att ange dessa manuellt.
Nu tror jag iofs inte att BBB byter DNS-servrar till höger & vänster, så jag skulle kunna ange dem statiskt ändå, men se det vill jag inte göra :)
Anledningen till att jag fått låna routern är att öva på att konfigurera den, och detta är en nöt jag inte lyckats knäcka.
Min conf ser ut såhär (för tillfället!):

Kod:
Current configuration : 1360 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 <hemligt! :)>
enable password <hemligt! :)>
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef   
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.100
!
ip dhcp pool lanpool
   network 192.168.1.0 255.255.255.0
   dns-server 208.67.222.222 208.67.220.220
   default-router 192.168.1.1
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
duplex auto
 speed auto
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
ip classless
!
no ip http server
ip nat inside source list 10 interface FastEthernet0/0 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 remark *** NAT access ***
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 access-class 10 in
 password <hemligt! :)>
 login
!
scheduler allocate 20000 1000
!
end

Just nu kör jag med OpenDNS-servrarna på dns, men jag gillar inte dem riktigt.
Om det ser förvirrande ut med interfacen så beror det på att det sitter en switchmodul i, där fa0/1/0 0/1/3 ligger på vlan1. Använder altså denna istället för fa0/1.

Alla förslag mottages tacksamt!

Mvh
P


24 jan 2010, 12:58
Profil ICQ

Blev medlem: 09 jul 2008, 17:19
Inlägg: 6437
OS: Kubuntu
Svara med citat
Inlägg Re: Cisco-router (IOS) & DNS
Jag kan inget om just Cisco's routrar...
Men jag hade provat att inte ange några DNS-servrar överhuvudtaget eller satt dom till IPnr = 0.0.0.0
Eller om det finns någon inställning för "DNS Relay" i routern.
Mina förslag kräver att du måste starta om både dator och router några gånger. Trial and error -metoden :)
Har du någon manual? Så är jag nyfiken på den!

_________________
Här brukar jag hålla till


24 jan 2010, 18:12
Profil
Användarvisningsbild

Blev medlem: 30 jan 2007, 15:59
Inlägg: 1258
Ort: Kristianstad/Sverige
OS: Fedora
Svara med citat
Inlägg Re: Cisco-router (IOS) & DNS
Rune.K skrev:
Jag kan inget om just Cisco's routrar...
Men jag hade provat att inte ange några DNS-servrar överhuvudtaget eller satt dom till IPnr = 0.0.0.0
Eller om det finns någon inställning för "DNS Relay" i routern.
Mina förslag kräver att du måste starta om både dator och router några gånger. Trial and error -metoden :)
Har du någon manual? Så är jag nyfiken på den!


Hmm har ingen direkt manual, men det finns ju mkt när man googlar (inget som jag hittat på denna topic dock).
Har provat att utelämna DNS helt, men det enda som händer då är att dhcp-klienten (min dator) inte får någon DNS överhuvudtaget och namnuppslag inte funkar.
Sätter jag den till 0.0.0.0 så antar jag att de siffrorna hamnar på klienten och då lär det inte heller funka. (Väl?)

Om du vill söka lite själv så heter routern Cisco 2811 och operativsystemet IOS. Blanda bara inte ihop det med Catalyst eller CatOS som de kör i sina switchar :)
Man kan göra fantastiskt avancerade saker med de här prylarna! (allt är iofs relativt ;) )


24 jan 2010, 18:57
Profil ICQ

Blev medlem: 09 jul 2008, 17:19
Inlägg: 6437
OS: Kubuntu
Svara med citat
Inlägg Re: Cisco-router (IOS) & DNS
Pinky skrev:
...
Om du vill söka lite själv så heter routern Cisco 2811 och operativsystemet IOS. Blanda bara inte ihop det med Catalyst eller CatOS som de kör i sina switchar :)
Man kan göra fantastiskt avancerade saker med de här prylarna! (allt är iofs relativt ;) )

Jag ska kolla vid tillfälle, kan inte lova något...
Kul om du berättar om lösningen, som du troligtvis hittar innan jag gör det. :)

_________________
Här brukar jag hålla till


24 jan 2010, 19:22
Profil
Användarvisningsbild

Blev medlem: 30 jan 2007, 15:59
Inlägg: 1258
Ort: Kristianstad/Sverige
OS: Fedora
Svara med citat
Inlägg Re: Cisco-router (IOS) & DNS
Min senaste tanke är att använda routern som DNS relay och sedan ange routern som DNS i min DHCP-konfiguration, men även där verkar det som att jag måste ange DNS-servrar manuellt. :)


24 jan 2010, 19:25
Profil ICQ
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 5 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 10 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011