Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 23 jan 2021, 20:31



Svara på tråd  [ 92 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5  Nästa
 Bug i LibreOffice Writer 
Författare Meddelande

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Jag har den versionen av LibreOffice som följer med vid installationen av Linux Mint 17.
Jag har samma problem på två av mina datorer. Jag har också provat att installera om hela systemet på en partition och i virtualbox, men problemet är kvar.
Jag har en tredje dator, men den har jag Xubuntu av en äldre version, 12 eller 13 tror jag, men på den fungerar det.
Jag installerade Linux Mint 17 på mina föräldrars dator i sommar, på den finns inte felet, men det var en 64-bitars. Alla mina är 32-bitars. Jag har också märkt på flera forum att ingen har lyckats återskapa problemet på en 64-bitars.


07 sep 2015, 20:43
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Jag skrev in kommandot som du sa:
sudo apt-get purge hunspell-sv-se

Då kom följande, det ser ut som att den tog bort nåt mer, ifall det är av vikt så klistrade jag in vad som hände:

henrik@hp ~ $ sudo apt-get purge hunspell-sv-se
[sudo] password for henrik:
Läser paketlistor... Färdig
Bygger beroendeträd
Läser tillståndsinformation... Färdig
Följande paket har installerats automatiskt och är inte längre nödvändiga:
libgsoap4 libvncserver0
Use 'apt-get autoremove' to remove them.
Följande paket kommer att TAS BORT:
hunspell-sv-se* myspell-sv-se*
0 att uppgradera, 0 att nyinstallera, 2 att ta bort och 64 att inte uppgradera.
Efter denna åtgärd kommer 2 215 kB att frigöras på disken.
Vill du fortsätta? [J/n] J
(Läser databasen ... 230071 filer och kataloger installerade.)
Tar bort myspell-sv-se (1.51-1) ...
Tar bort hunspell-sv-se (1:4.2.1-0ubuntu1.1) ...
Raderar konfigurationsfiler för hunspell-sv-se (1:4.2.1-0ubuntu1.1) ...
henrik@hp ~ $

Sen startade jag LibreOffice i svenskt läge med synonymordlistan Svenska (Sverige) och då kraschar inte LibreOffice och jag kan använda synonymordlistan.


07 sep 2015, 20:50
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Henrik Jansson skrev:
Jag har den versionen av LibreOffice som följer med vid installationen av Linux Mint 17.
Ok, då föll teorin att problemet bara uppstår om man installerar någon annan version än den 'påbjudna'.

Henrik Jansson skrev:
Jag skrev in kommandot som du sa:
sudo apt-get purge hunspell-sv-se

Då kom följande, det ser ut som att den tog bort nåt mer, ifall det är av vikt ...
Det är det inte. När du åter installerar ordlistan för stavningskontroll, kan du nöja dig med att installera hunspell-sv-se. Det andra paketet är överflödigt.

Henrik Jansson skrev:
Sen startade jag LibreOffice i svenskt läge med synonymordlistan Svenska (Sverige) och då kraschar inte LibreOffice och jag kan använda synonymordlistan.
Då har du bekräftat teorin, dvs. att det bara kraschar när båda är installerade. Tack! Jag vidarebefordrade den observationen genom ett nytt inlägg i felrapporten.

@Lao Tzu: Jag tror att iakttagelserna, som du delade med dig av i ditt senaste inlägg, skulle passa bättre i felrapporten. Tvivlar på att någon här i forumet är tillräckligt insatt i hur LibreOffice samverkar med berörda skrivbordsmiljöer och arkitekturer, för att kunna dra någon slutsats av det.


07 sep 2015, 22:46
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Kom på en sista(?) sak som kan vara värd att pröva:

Versionen av ordlistan för stavningskontroll, som installeras genom paketet hunspell-sv-se, är rätt gammal (version 2.22 från december 2013). Därför föreslår jag att du:


Jag är alltså ute efter att testa om den versionen möjligen funkar tillsammans med synonymordlistan på din maskin.


08 sep 2015, 14:28
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Jag har löst problemet för 10 minuter sedan. Min LibreOffice Writer Version: 5.0.1.2 fungerar nu utan någon form av kraschar. Det var inte lätt. Kort kan jag säga följande, när du avinstallerar LibreOffice gäller det verkligen få med allt. I några sällsynta fall som med LibreOffice kan Ubuntu/Linux Mint missa en del. Det gäller verkligen att göra en så kallat "clean install". Jag får återkomma nu ska jag se på fotbollen.


08 sep 2015, 19:11
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Gunnar Hjalmarsson skrev:
Kom på en sista(?) sak som kan vara värd att pröva:

Versionen av ordlistan för stavningskontroll, som installeras genom paketet hunspell-sv-se, är rätt gammal (version 2.22 från december 2013). Därför föreslår jag att du:


Jag är alltså ute efter att testa om den versionen möjligen funkar tillsammans med synonymordlistan på din maskin.


Ok. Jag installerade tillägget och startade sedan om libreoffice. Då kom felet tillbaka.
Om jag inaktiverar tillägget och sedan startar om libre office så funkar det.
( Det kanske alltid är så att man måste starta libreoffice efter att ha aktiverat eller avaktiverat ett tillägg.)


08 sep 2015, 21:03
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Tack, Henrik, då föll den idén också. :( Det stämmer med vad Niklas skrev i felrapporten för en stund sedan - han tror det kan handla om versionen av själva hunspell-programmet. Se mitt svar i felrapporten, och gör gärna ett försök om du orkar. ;)


08 sep 2015, 21:47
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Nedan utfördes innan jag utförde rensning av LibreOffice och en nyinstallation.

Dock testade jag med att avinstallera hunspell-sv-se och installerar version 2.37 av tillägget från libreoffice.org. Men problemet är fortfarande närvarande. Ingen förändring.

Övrigt.

Jag vet inte om det har med hunspell-sv-se att göra. hunspell-sv-se fungerar alldeles utmärkt efter min nyinstallation. Inga fel alls. Men jag har undvikt mythes-sv. Vågar inte installera mythes-sv. Jag anser personligen att problemet kan härröras till mythes-sv. mythes-sv har ett betydligt lägre versions nummer än övriga mythes. Möjligtvis kan det vara så mythes-sv och hunspell-sv-se inte lirar så bra tillsammans. Eller omvänt. Men tveklöst är det något med mythes-sv.

Jag hävdar också fortfarande tvärsäkert följande "Så med andra ord så uppstår inte högerklickar problemet som dryftas i tråden om man väljer Linux Mint egna val LibreOffice Writer version"


08 sep 2015, 23:02
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
@Pink Panther: Har du läst inläggen i felrapporten? Niklas Johansson, som är engagerad i LibreOffice-utveckling, har bekräftat problemet med en nyinstallerad 32-bitars Mint 17.2.

Pink Panther skrev:
Möjligtvis kan det vara så mythes-sv och hunspell-sv-se inte lirar så bra tillsammans.
Ja, det är väl det vi har kommit fram till.

Nu är jag nyfiken på om Niklas teori om version av själva hunspell-programmet (alltså inte den svenska ordlistan) kan ha något med saken att göra.


08 sep 2015, 23:26
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Jag har läst felrapporten nu. Ja! Då har vi kommit fram till samma slutsats.

Jag har inte ett "nyinstallerad 32-bitars Mint 17.2" Men Mint 17.2 uppdaterat från tidigare versioner av Linux Mint enligt alla konstens regler. Den manövern anser jag mig behärska bättre än de flesta. Men det är möjligt att ändå inte blir samma sak. Jag borde också få högerklickar problemet "Linux Mint LibreOffice Writer version" men ett faktum är när jag backade version av LibreOffice uppstod det inte.

Men nu när jag sitter här skriver så slår dig mig att det förmodligen var i den tidigare versionen Linux Mint som jag utförde de experimentet.

Så jag backar, ni har rätt. Jag har fel.

För det här högerklickar problemet har funnits med ett tag i nyare versioner av LibreOffice. Men jag har inte hittat någon information om problemet och ingen har uppmärksammat problemet i forumet tidigare.

Jag har inte velat uppmärksamma problemet för ni brukar inte lyssna eller bry er om mina åsikter.


09 sep 2015, 00:11
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Pink Panther skrev:
... för ni brukar inte lyssna eller bry er om mina åsikter.
Trist att du känner så. Förmodligen hänger det ihop med vad du skriver om. Om jag minns rätt, skriver du inte sällan om ämnen som ligger utanför "kärnan", dvs. Ubuntu och officiella underdistributioner, vilket skulle kunna vara en förklaring.


09 sep 2015, 16:48
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Bekräftar nedanstående Gunnar.

"I successfully installed and run version 1.3.3-3 (from the Ubuntu 15.04 archive) of the hunspell and libhunspell-1.3-0 packages"

Jag har själv utfört samma manöver som du Gunnar.

Inga problem med mythes-sv och hunspell-sv-se längre. Med andra ord "högerklickar problemet" förfaller åtgärdat. Eller "no dependency complaints" längre.

LibreOffice
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Språkinställning: sv-SE (sv_SE.UTF-8)


11 sep 2015, 22:07
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ok!
Jag har fullt upp med annat nu så jag hinner inte testa nåt nu, men hur gör man för att installera ett paket för 15.04 om man använder Linux Mint 17 som väl baseras på 14.04? För sånt som tillhör 15.04 kan man väl inte hitta med paketinstalleraren?


11 sep 2015, 22:11
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Pink Panther skrev:
Bekräftar nedanstående Gunnar.

"I successfully installed and run version 1.3.3-3 (from the Ubuntu 15.04 archive) of the hunspell and libhunspell-1.3-0 packages"

Jag har själv utfört samma manöver som du Gunnar.

Inga problem med mythes-sv och hunspell-sv-se längre. Med andra ord "högerklickar problemet" förfaller åtgärdat.
Det var en god nyhet, Pink Panther. :)

Då kanske det helt enkelt är ett 14.04-problem snarare än ett Mint-problem. Kan ni som råkat ut för "högerklick-problemet" bekräfta det, dvs. har det alltid varit på 14.04-installationer som problemet visat sig?

Henrik Jansson skrev:
... hur gör man för att installera ett paket för 15.04 om man använder Linux Mint 17 som väl baseras på 14.04? För sånt som tillhör 15.04 kan man väl inte hitta med paketinstalleraren?
Nej, det stämmer.

Hittade ingen bra länk, så jag ger dig direktlänkar till .deb-filerna (för 32-bitars arkitektur) i stället:

http://launchpadlibrarian.net/188116205/hunspell_1.3.3-3_i386.deb

http://launchpadlibrarian.net/188116199/libhunspell-1.3-0_1.3.3-3_i386.deb

Du laddar alltså ned de två filerna. Därefter:

cd Hämtningar
sudo dpkg -i hunspell_1.3.3-3_i386.deb libhunspell-1.3-0_1.3.3-3_i386.deb



Hmm.. Kan bli kinkigt att få dem att ta in hunspell 1.3.3-3 i trusty-arkivet. Det går att få in paketet i "backports", men då blir det inte installerat automatiskt genom uppdateringshanteraren.

@Henrik, @Lao Tzu: Bra om ni kan testa medan jag funderar på det.


11 sep 2015, 23:11
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Gunnar jag tror det kan bli problem med ditt förslag på hunspell_1.3.3-3_i386.deb. Jag testade det blev protest.

Jag har hunspell 1.3.3-3ubuntu3 153 kB.

Det funkar också lika bra med den nyaste versionen av Ubuntus egna version av libhunspell som har versionsnummer 2 i slutet. Din har 3.

Men jag testar med ditt förslag libhunspell-1.3-0_1.3.3-3_i386.deb Det ska förmodligen inte påverka något. Nej! Det påverkade inget. Den fungerade. Det var väntat.

Min version av Linux Mint är följande:

Senaste versionen av Linux Mint.

Distributor ID: LinuxMint
Description: Linux Mint 17.2 Rafaela
Release: 17.2
Codename: rafaela


12 sep 2015, 00:01
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Pink Panther skrev:
Gunnar jag tror det kan bli problem med ditt förslag på hunspell_1.3.3-3_i386.deb. Jag testade det blev protest.
Vad för slags protest? 1.3.3-3 är versionen som finns i 15.04-förrådet.

Förresten har du 32 eller 64 bitar? Länkarna går till versionen för 32 bitar.

Pink Panther skrev:
Jag har hunspell 1.3.3-3ubuntu3 153 kB.
Det är senaste versionen i 15.10-förrådet, som är anpassad för att byggas med gcc5 (som definitivt inte finns i 14.04). Testade inte den, men då det väsentliga enligt felrapporten är att byta till uppströms version 1.3.3, kändes det säkrast att hänvisa till 1.3.3-3.

Pink Panther skrev:
Det funkar också lika bra med den nyaste versionen av Ubuntus egna version av libhunspell som har versionsnummer 2 i slutet. Din har 3.

Men jag testar med ditt förslag libhunspell-1.3-0_1.3.3-3_i386.deb Det ska förmodligen inte påverka något. Nej! Det påverkade inget. Den fungerade. Det var väntat.
Funkar det nu? Jag hänger inte med på detta sista.


12 sep 2015, 00:34
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Jag har 32 bitar.

hunspell_1.3.3-3_i386.deb 46,2 kB (46188 byte)

hunspell_1.3.3-3ubuntu3_i386.deb 46,1 kB (46122 byte)


libhunspell-1.3-0_1.3.3-3ubuntu3_i386.deb 117,9 kB (117932 byte)

libhunspell-1.3-0_1.3.3-3_i386.deb 117,3 kB (117328 byte)

"versionsnummer 2 i slutet" Var fel av mig.


12 sep 2015, 01:00
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Menar du att antingen 1.3.3-3 eller 1.3.3-3ubuntu3 funkar, dvs. installerar utan felmeddelanden och löser "högerklickproblemet"?


12 sep 2015, 01:04
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Svar Ja!


12 sep 2015, 01:05
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Nu har jag hunspell_1.3.3-3ubuntu3_i386.deb 46,1 kB (46122 byte) och ditt förslag libhunspell-1.3-0_1.3.3-3_i386.deb 117,3 kB (117328 byte)

Det funkar hur bra som helst utan felmeddelande.


12 sep 2015, 01:09
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 92 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011