Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 23 jan 2021, 22:39



Svara på tråd  [ 92 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5  Nästa
 Bug i LibreOffice Writer 
Författare Meddelande
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Du får rätt Gunnar. Det förfaller att vara något problem med ( wily ), libhunspell-1.3-0_1.3.3-3ubuntu3_i386.deb 117,9 kB (117932 byte) paketet. ( wily ), libhunspell-1.3-0_1.3.3-3ubuntu3_i386.deb 117,9 kB (117932 byte) klagar nu över att inte rätt beroende är tillfredsställda.

Men däremot ( wily ) hunspell_1.3.3-3ubuntu3_i386.deb 46,1 kB (46122 byte) fungerar utan någon form av klagomål.

Varför det blev så här har jag i stunden ingen rimlig förklaring att delge dig Gunnar eller övriga läsare. Det jag vet är följande. När jag installerade ovanstående paket första gången så fungerade paketet ( wily ), libhunspell-1.3-0_1.3.3-3ubuntu3_i386.deb utan någon som helst protest.

Det var när jag började experimentera eller leka med dina förslag som problemen uppstod.

Men om besökarna av tråden endast håller sig till vad Gunnar föreslår så ska allt fungerar utan några som helst problem.

hunspell_1.3.3-3_i386.deb 46,2 kB (46188 byte)

libhunspell-1.3-0_1.3.3-3_i386.deb 117,3 kB (117328 byte)

Övrigt: Ingen nybörjare eller mindre erfaren användare ska experimentera eller utföra det vi nu talar om i tråden. Användaren bör behärska pakethanteraren Synaptic funktioner vad berör pakethantering eller terminalens funktioner.


12 sep 2015, 11:19
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Min sammanfattning av högerklicknings problemet med LibreOffice och LTS Long Term Support (LTS) version 32 bit.

Problemet berör endast Linux Mint 17 versioner 32 bit eller möjligtvis också andra underdistributioner till Ubuntu 14.04.3 LTS Long Term Support (LTS) version 32 bit.

Om jag förstått saken rätt också Xubuntu 14.04 32 bit enligt ett inlägg i tråden. Samma problem bör rimligtvis också vara närvarande i andra underdistributioner till Ubuntu 14.04.3 LTS Long Term Support (LTS) version 32 bit.

Problemet med högerklickning i LibreOffice uppstår endast om användaren installerar mythes-sv i Linux Mint 17 versioner 32 bit eller i någon annan underdistribution till Ubuntu Long Term Support (LTS) 32 bit.

Undviker användaren mythes-sv eller inte installerar mythes-sv så fungerar högerklickningen i LibreOffice med en normal konfigurationen av Linux Mint 17 versioner 32 bit.

Jag har konstaterat att problemet med högerklickning uppstår endast om användaren installerar mythes-sv när någon av ovanstående förutsättningar är uppfyllda.

Tar användaren bort paketet mythes-sv eller rättar sagt avinstallerar mythes-sv så fungerar högerklickning åter med den normal konfiguration av Linux Mint 17 versioner 32 bit och LibreOffice.


12 sep 2015, 13:22
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Tack för den sammanfattningen, Pink Panther. Håller med. Skrev ungefär samma sak i en Ubuntu felrapport.

Fast det där med att avinstallera (eller inte installera) mythes-sv är en workaround som jag inte är så förtjust i. Kan ju i någon mån bero på att det var jag som skapade paketet (och därmed - indirekt - problemet).

Nu har jag gjort en ny trusty-version av hunspell-programmen i ett PPA:

https://launchpad.net/~gunnarhj/+archive/ubuntu/hunspell-thesaurus

Tanken är att "högerklickproblemet" skall försvinna om originalversionen (1.3.2-6ubuntu2) av hunspell och libhunspell-1.3-0 byts ut mot versionen i PPA:et. Om ni som har problemet bekräftar det, kommer jag att föreslå den ändringen i Ubuntu-förrådet för trusty. (Bättre, alltså, att testa detta än att testa version 1.3.3-3 som föreslogs i tidigare inlägg.)


12 sep 2015, 19:56
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ok, ska jag följa instruktionen på den sidan för hur man installerar det?


14 sep 2015, 08:57
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Henrik Jansson skrev:
Ok, ska jag följa instruktionen på den sidan för hur man installerar det?
Ja... eller den här instruktionen (det finns många sätt).


14 sep 2015, 09:34
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Dina förändringar fungerar inte Gunnar.

System.

Senaste versionen av Linux Mint.

Distributor ID: LinuxMint
Description: Linux Mint 17.2 Rafaela
Release: 17.2
Codename: rafaela


LibreOffice
Version: 5.0.1.2
Build ID: 00m0(Build:2)
Språkinställning: sv-SE (sv_SE.UTF-8)

Bra försök eller egentligen bra jobbat Gunnar. Men något är fel. Dina förändringar fungerar inte. Negativt resultat. Högerklicknings problemet är fortfarande närvarande.

Jag installerade åter hunspell_1.3.3-3_i386.deb 46,2 kB (46188 byte) libhunspell-1.3-0_1.3.3-3_i386.deb 117,3 kB (117328 byte) så försvann problemen omedelbart.


14 sep 2015, 11:36
Profil

Blev medlem: 23 jan 2009, 13:36
Inlägg: 31
OS: Debian
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Pink Panther skrev:
Dina förändringar fungerar inte Gunnar.


Ser nu att det fanns en uppföljande kodändring uppströms som täcker samma kod och är märkt som relaterad till den andra:

https://github.com/hunspell/hunspell/co ... 371cce6340

Kan vara det som är saknade pusselbiten för att det ska fungera.


14 sep 2015, 11:54
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
a_jonsson skrev:
Pink Panther skrev:
Dina förändringar fungerar inte Gunnar.
Ser nu att det fanns en uppföljande kodändring uppströms som täcker samma kod och är märkt som relaterad till den andra:

https://github.com/hunspell/hunspell/co ... 371cce6340

Kan vara det som är saknade pusselbiten för att det ska fungera.
Kan ju vara värt ett försök. Jag har just uppdaterat PPA:et med den ändringen, så versionen där är nu 1.3.2-6ubuntu2.1~ppa2.

Kan du testa igen Pink Panther?

P.S. Vill gärna framhålla att om vi lyckas lösa problemet på det här sättet, så är det tack vare att a_jonsson visade oss på de relevanta ändringarna, först i felrapporten, och nu här. Tack Anders!


14 sep 2015, 13:01
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Negativt resultat. Fungerar inte med den nya koden. Något är fortfarande fel.

Övrig information.

Delvis fungerande om användaren undviker nedanstående.

Markerar användaren en mening eller ord med siffror eller bokstäverna å, ä eller ö så kraschar LibreOffice omedelbart.


14 sep 2015, 13:52
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ok, trist.

Har gjort ett tredje försök i PPA:et (version 1.3.2-6ubuntu2.1~ppa4). Den här gången har jag patchat så att den källkodsfil vi mekkat med hittills nu är identisk med källkodsfilen i version 1.3.3.

Vågar jag be om ett nytt test?


14 sep 2015, 15:47
Profil

Blev medlem: 23 jan 2009, 13:36
Inlägg: 31
OS: Debian
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Gunnar Hjalmarsson skrev:
Ok, trist.

Har gjort ett tredje försök i PPA:et (version 1.3.2-6ubuntu2.1~ppa4). Den här gången har jag patchat så att den källkodsfil vi mekkat med hittills nu är identisk med källkodsfilen i version 1.3.3.

Vågar jag be om ett nytt test?


Skapade en virtuell 32-bits Xubuntu 14.04-maskin att testa problemet med.

Kunde till att börja med bekräfta att problemet existerar med hunspell 1.3.2-6ubuntu2. Libreoffice Writer kraschade vid högerklick även på ord utan å, ä och ö.

Installerade sedan din 1.3.2-6ubuntu2.1~ppa4, och dessa ändringar är tillräckliga för att det ska fungera, även med å, ä och ö. Kan ändra ord med synonymordboken utan problem.


14 sep 2015, 16:30
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Angående patch "version 1.3.2-6ubuntu2.1~ppa4"

Jag är ledsen men svaret NEJ! Inte riktigt. Men nära.

å,ä,ö problemet löst.

Det kraschar fortfarande om du högerklickar men nu endast om siffror finns med i bilden som telefonnummer, postnummer med mera. Men nu är ni båda nära en lösning.

Jag installerade åter hunspell_1.3.3-3_i386.deb 46,2 kB (46188 byte) libhunspell-1.3-0_1.3.3-3_i386.deb 117,3 kB (117328 byte) så försvinner alla problem omedelbart.

Ingen krasch oavsett vad jag markerar eller högerklickar på.

Det är märkligt. Men så är det.


14 sep 2015, 17:37
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Tack a_jonsson och Pink Panther! Ok, så vi fick vara helt glada i en dryg timme, och sedan kom PP och lade sordin på stämningen. ;)

Egentligen skulle man förstås vilja peta in hunspell 1.3.3-3 i förrådet för Ubuntu trusty. Problemet är att de som slår vakt om stabiliteten i arkivet förmodligen inte skulle tillåta det, så det är skälet till att jag försöker gå den andra vägen och modifiera den befintliga versionen.

@Pink Panther: Skulle du kunna ge något väldigt konkret exempel på hur du går tillväga när du blandar in siffror?

@a_jonsson: Kan du på din Xubuntu-installation reproducera problemet som PP beskriver?

@Henrik: I det här läget vore det bra om du också kunde testa på din Mint-maskin.


14 sep 2015, 18:40
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Markerar användaren mening, ord med siffror eller endast siffror och högerklickar så kraschar LibreOffice omedelbart. Kan eventuellt gälla andra specialtecken/tecken har inte testat @ med flera.

Det kan vara som nedan

Med vänlig hälsning

Kalle Kula
Kallekulavägen 101 D
555 55 kallekula city

Telefon: 000-000 00 00

E-post: xxxxx@xxxxx.com


eller något som "Stad 2015-08-20", hunspell_1.3.3-3_i386.deb 46,2 kB (46188 byte) med siffror.


14 sep 2015, 19:17
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ok, vilken variant är det jag ska installera nu?
Skulle du kunna lägga in den i ett inlägg som en deb.fil som du gjorde första gången i den här tråden?


14 sep 2015, 19:21
Profil

Blev medlem: 23 jan 2009, 13:36
Inlägg: 31
OS: Debian
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Gunnar Hjalmarsson skrev:
Tack a_jonsson och Pink Panther! Ok, så vi fick vara helt glada i en dryg timme, och sedan kom PP och lade sordin på stämningen. ;)

@a_jonsson: Kan du på din Xubuntu-installation reproducera problemet som PP beskriver?


Jag kan reproducera det, siffror fungerar tydligen inte i 1.3.2-6ubuntu2.1~ppa4. Det kraschar på ord som Apa1 eller 2015.


14 sep 2015, 19:58
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ok, så om det man markerar innehåller siffror, så kraschar programmet om man högerklickar. Funkar det så länge det man markerar inte innehåller siffror, även om det finns siffror på andra ställen i dokumentet?

Henrik Jansson skrev:
Skulle du kunna lägga in den i ett inlägg som en deb.fil som du gjorde första gången i den här tråden?
Visst. Det är de här filerna:

hunspell_1.3.2-6ubuntu2.1~ppa4_i386.deb

libhunspell-1.3-0_1.3.2-6ubuntu2.1~ppa4_i386.deb


Det lutar ju åt att även Henrik kommer att göra samma observation i fråga om siffror. Jag undrar vad ni tycker bör göras. Är det meningsfullt att föreslå att den senaste PPA-versionen går in i trusty-arkivet? Uppenbarligen fixas inte problemet helt, men det vore en förbättring.

Jag skulle förstås kunna fråga någon om version 1.3.3-3. Misstänker att de då föreslår att den går in i trusty-backports, vilket skulle innebära att man explicit behöver ange ett kommando för att den versionen skall bli installerad över den befintliga.


14 sep 2015, 20:16
Profil
Användarvisningsbild

Blev medlem: 08 feb 2009, 01:13
Inlägg: 3050
Ort: Luna
OS: Linux Mint
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
"senaste PPA-versionen går in i trusty-arkivet?"

Svår och känslig fråga Gunnar. Du har skapat paketet. Hur jag än svarar så skapar det bekymmer eller missnöje.

Nej! Det tycker jag inte. Inte bra att skicka ut något som kraschar. Även om det är en klar förbättring.

Jag föreslår 1.3.3-3. Jag förslår trusty-backports. "explicit behöver ange ett kommando för att den versionen skall bli installerad över den befintliga"

"fråga någon om version 1.3.3-3"

Så får vi höra deras åsikt.

Nu berör problemet inte endast Linux Mint användare utan också Xubuntu och eventuellt andra underdistributioner till Ubuntu.


14 sep 2015, 21:11
Profil

Blev medlem: 10 feb 2008, 22:06
Inlägg: 760
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Ska jag ta bort något paket innan jag installerar de två filerna?


14 sep 2015, 21:58
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 12:49
Inlägg: 2786
Ort: Göteborg
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Bug i LibreOffice Writer
Henrik Jansson skrev:
Ska jag ta bort något paket innan jag installerar de två filerna?
Nej, det behövs inte. Beroende på vilka versioner du hade innan innebär det en upp- eller nedgradering. De gamla versionerna tas då bort automatiskt.

Förresten... Du bör installera båda filerna i ett och samma kommando:
Kod:
sudo dpkg -i hunspell_1.3.2-6ubuntu2.1~ppa4_i386.deb libhunspell-1.3-0_1.3.2-6ubuntu2.1~ppa4_i386.deb


14 sep 2015, 22:20
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 92 inlägg ]  Gå till sida Föregående  1, 2, 3, 4, 5  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 2 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011