Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 26 apr 2018, 05:03

Kategoriregler


I detta forum diskuterar vi frågor relaterade till fysisk hårdvara.
Ubunturelaterade frågor ska ställas i Hårdvara



Svara på tråd  [ 14 inlägg ] 
 HOWTO SB X-Fi Extreme Audio + Alsa drivar 
Författare Meddelande
Användarvisningsbild

Blev medlem: 10 maj 2007, 21:24
Inlägg: 2153
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg HOWTO SB X-Fi Extreme Audio + Alsa drivar
Fick igång ett Sound Blaster X-FI Extreme Audio med dem nya drivarna, äntligen. :)
Efter ja startade om datan, så visade det ett X (kryss) över ljudikonen uppa vid klockan, kan ändra där upp o ner
men ingen skillnad på ljudvolym, inte heller blir det nån skillnad om ja drar baren i audacious för ljudet. samma volym ändå.
samma med tangentbordet, fungerar inte att höja där längre heller.
enda är så klart volymen på högtalaran, där får ja ändra ljudet. gick att ändra i vlc oxå.
så ja kan inte säga om ni kan ändra ljudet som vanligt igen, går säkert att ordna på något sätt.

Börja att tanka ner dem senaste drivarna från alsa:s sida.
ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16.tar.bz2

Lägger till sidan med för det kommer ju alltid nyare så kanske inte är den versionen när du/ni ser detta. (tänk då på att ändra filnamn oxå)
http://www.alsa-project.org/main/index.php/Main_Page

se till så ni har build-essential, öppna terminal
Kod:
sudo apt-get install build-essential


Kod:
cd dit_du_har_tankat_drivarna


packa upp dem, sen installera.
Kod:
tar xvf alsa-driver-1.0.16.tar.bz2


Kod:
cd alsa-driver-1.0.16


Kod:
sudo ./configure


Kod:
make


Kod:
sudo make install


Starta om datan


03 mar 2008, 14:27
Profil

Blev medlem: 14 apr 2007, 23:11
Inlägg: 82
OS: Windows
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
tack! underbar guide!


25 mar 2008, 09:41
Profil
Användarvisningsbild

Blev medlem: 10 maj 2007, 21:24
Inlägg: 2153
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
ollebro skrev:
tack! underbar guide!


Hoppas det fungerade för dig bara. alltid kul att veta när det ändå varit såna problem med dem länge. :)

_________________
Bild


25 mar 2008, 16:18
Profil

Blev medlem: 14 apr 2007, 23:11
Inlägg: 82
OS: Windows
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
zenbios skrev:
ollebro skrev:
tack! underbar guide!


Hoppas det fungerade för dig bara. alltid kul att veta när det ändå varit såna problem med dem länge. :)

ja, innan har alltid ljudet funkat direkt när jag installerat ubuntu med denna gång så fick jag av någon konstig anledning inget, men tack vare din guide så funkar det super nu :D


25 mar 2008, 17:16
Profil

Blev medlem: 14 apr 2007, 23:11
Inlägg: 82
OS: Windows
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
det var då förbaskat konstigt! nu efter en reboot så finns inte det något ljud ur mitt ljudkort längre! jag har ett Creative SoundBlaster Audigy SE och hade ljud i det tidigare idag.

ifall jag skriver
Kod:
asoundconf list

så kommer
Citat:
Names of available sound cards:
Intel
upp, alltså inget Creative kort där inte.

vad gör jag nu då? ???


EDIT: nu funkade det helt plötsligt, vet inte vad som händer :P


25 mar 2008, 19:04
Profil

Blev medlem: 27 apr 2008, 12:24
Inlägg: 3
OS: Ubuntu
Utgåva: 12.04 Precise Pangolin LTS
Svara med citat
 Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
Hmmm...

Detta verker inte funka 100% för mig, Jag har SB X-Fi Extreme Audio från Creative.
3st 3,5mm jack i datan för ljudet, Ingen av dem funkar, Allvarligt talat så kan jag precis på att jag har 64 bit :s
Stökar nog till det en del...

Om du (Ljudkortens frälste) lyckas hitta ngt alternativ (Jag har fått nog av google för idag ;) ) så skriv gärna här ;D

Jag bevakar tråden ;)

Edit 12/8: Har numera 32-Bit, Tycker inte att 64-Bitars är helt moget för marknaden....


Senast redigerad av Tukotih 12 aug 2008, 10:40, redigerad totalt 1 gång.



27 apr 2008, 12:42
Profil
Användarvisningsbild

Blev medlem: 10 maj 2007, 21:24
Inlägg: 2153
OS: Ubuntu
Utgåva: 14.04 Trusty Tahr LTS
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
audio, music, extream gamer har alla fungerat på detta sättet för mig.
och ja själv sitter med 64 bitars. dock fungerar inte volymkontrollerna
för tex audacious för mig, bara på högtalar kontrollen.
men ska kolla lite mer på detta i dagarna vilken av alla drivrutiner som fungerar bäst,
och så klart att man ska kunna höja volymen som vanligt.
så ja återkommer.

_________________
Bild


21 maj 2008, 18:11
Profil

Blev medlem: 25 mar 2008, 18:15
Inlägg: 2
OS: Ubuntu
Utgåva: 10.04 Lucid LTS
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
Jag har ett extreme audio och lyckas inte få något ljud med alsa, efter att jag kört din guide. Däremot laddade jag ned senaste OSS vilket fungerar, dock inte på flash.


27 maj 2008, 18:53
Profil

Blev medlem: 27 jun 2008, 21:35
Inlägg: 21
Ort: Kattarp
OS: Crunchbang
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
Hej. Följde din guide men fick ändå inte ljudet att funka. när jag kör kommandot:

Kod:
asoundconf list


så får jag fram följande ljudkort:

I82801DBICH4(skulle tro att detta är mitt integrerade Realtek AC97 ljudkort)

respektive:

CA0106(Skulle tro att detta är mitt Creative Sound Blaster X-FI Xtreme Audio som är ett PCI-kort)

och ändå så står den aktuella ljudenheten inställd på den sistnämda(CA0106) och får ändå inget ljud. i volymkontrollen står volymen på max ocj jag har dock testat att spela upp en musik-cd och sedan testat att plugga in ljudkabeln till olika ljudingångar medans musiken spelades.

någon som har något förslag??? kanske någon av er som kan hjälpa mig via remote desktop eller vad nu linuxalternativet kallas?

jag bifogar en bild av volymkontroll-fönstret.

OBS!!! Jag startade även om datorn efter installationen. För problemet kan väl knappast bero på att jag kör Dualboot med Windows XP Home Edition Service Pack 3, jag tycker nämnligen inte att det låter så värst rimligt.


Bilagor:
Filkommentar: skärmdump
skärmbild.png
skärmbild.png [ 17.23 KiB | Visad 4151 gånger ]
27 jun 2008, 21:55
Profil YIM WWW

Blev medlem: 26 sep 2007, 19:49
Inlägg: 717
OS: Ubuntu
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
EvoKing skrev:
Hej. Följde din guide men fick ändå inte ljudet att funka. när jag kör kommandot:

Kod:
asoundconf list


så får jag fram följande ljudkort:

I82801DBICH4(skulle tro att detta är mitt integrerade Realtek AC97 ljudkort)

respektive:

CA0106(Skulle tro att detta är mitt Creative Sound Blaster X-FI Xtreme Audio som är ett PCI-kort)

och ändå så står den aktuella ljudenheten inställd på den sistnämda(CA0106) och får ändå inget ljud. i volymkontrollen står volymen på max ocj jag har dock testat att spela upp en musik-cd och sedan testat att plugga in ljudkabeln till olika ljudingångar medans musiken spelades.

någon som har något förslag??? kanske någon av er som kan hjälpa mig via remote desktop eller vad nu linuxalternativet kallas?

jag bifogar en bild av volymkontroll-fönstret.

OBS!!! Jag startade även om datorn efter installationen. För problemet kan väl knappast bero på att jag kör Dualboot med Windows XP Home Edition Service Pack 3, jag tycker nämnligen inte att det låter så värst rimligt.



Jag har inte heller fått mitt Creative Sound Blaster X-FI Xtreme Audio att fungera. När jag gör samma kommando får jag detta: 'Names of available sound cards:
I82801DBICH4
UART

Jag antar att den första raden anger det som är inbyggt i moderkortet och UART är soundblaster? Men varför ger den en annan beteckning än din?

När jag gör kommanadot: cat /proc/asound/cards får jag:

0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4
Intel 82801DB-ICH4 with ALC650D at irq 23
1 [UART ]: MPU-401 UART - MPU-401 UART
MPU-401 UART at 0x330, irq 5


12 aug 2008, 06:37
Profil

Blev medlem: 26 sep 2007, 19:49
Inlägg: 717
OS: Ubuntu
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
kerberos skrev:
Jag har ett extreme audio och lyckas inte få något ljud med alsa, efter att jag kört din guide. Däremot laddade jag ned senaste OSS vilket fungerar, dock inte på flash.


Jag har kört med guiden också men inte lyckats få något ljud med kortet.

Ursäkta min okunnighet men vad är OSS?
och var laddar man ner det?


12 aug 2008, 06:38
Profil

Blev medlem: 27 apr 2008, 12:24
Inlägg: 3
OS: Ubuntu
Utgåva: 12.04 Precise Pangolin LTS
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
OSS lärde jag mig om faktiskt igår kväll, Jag gjorde ett ganska stort framsteg med det.
Du laddar ner det här: http://www.4front-tech.com/download.cgi
På samma sida som nerladdningslinken finns (Efter du valt distrobution av Programmet) så finns det en PDF som är väldigt hjälpsam.
När du har lyckats (Utan felmeddelanden) så öppna en ny terminal och skriv osstest, Vänta tills processen har startat, Du bör höra ljud någon gång i processen.
Mer kan jag tyvär inte, Men lycka till!

PS. Versionen spelar ingen roll, Jag skulle råda dig att ta .deb eller .rpm (RPM är svårare men det funkar alltid garanterat)




Mitt Problem: Får ljud med OSS (Har gett upp osupportade ALSA) i osstest, Men mixern finns inte att välja, Kan man skapa en mixer och koppla den till mixern som hittas i OSS?


12 aug 2008, 10:38
Profil
Användarvisningsbild

Blev medlem: 20 okt 2007, 21:11
Inlägg: 5317
OS: Ubuntu
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
Tukotih skrev:
Mitt Problem: Får ljud med OSS (Har gett upp osupportade ALSA) i osstest, Men mixern finns inte att välja, Kan man skapa en mixer och koppla den till mixern som hittas i OSS?


U-F verkar ha gett upp Alsa och kör den här dvs OSS

http://ubuntuforums.org/showthread.php?t=780961

Tråden är på 34 sidor så 1.a och sista måste du läsa, snubben på slutet får iaf en mixer :)

Har ett Audigy kort själv så jag kan inte X-Fi.


12 aug 2008, 19:29
Profil
Användarvisningsbild

Blev medlem: 23 feb 2009, 04:16
Inlägg: 2108
Ort: Mora
OS: Ubuntu
Svara med citat
Inlägg Re: HOWTO SB X-Fi Extreme Audio + Alsa drivar
Hej. Ursäkta att jag tar upp tråden igen. Följde din guide men efter sista steget fick jag "fel 1".

Vad kan jag ha gjort fel?

_________________
Bild


29 apr 2009, 00:17
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 14 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011