Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 28 okt 2020, 09:28



Svara på tråd  [ 38 inlägg ]  Gå till sida 1, 2  Nästa
 [LÖST] Å, ä, ö borta vid start. 
Författare Meddelande
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg [LÖST] Å, ä, ö borta vid start.  Tråden är löst
Varje gång jag startar Ubuntu 8.04 så får jag ingen reaktion på tangenterna för å, ä, ö. Detta har kommit från att jag försökt fixa mitt nVidia-grafikkort, vilket jag efteråt fått fixa användbar grafik i "recovery mode".

Jag fixar detta genom gnome-keyboard-properties, där jag lägger till nytt svenskt tangentbord-layout, och sedan tar bort det svenska tangentborded som redan påstås vara in inställt.

Xorg.conf:
Kod:
Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "sv"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
EndSection

Section "Device"
   Identifier   "Configured Video Device"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
EndSection


Senast redigerad av Jojan 12 okt 2008, 13:17, redigerad totalt 1 gång.



26 aug 2008, 15:57
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Svensk tangentbordslayout heter se, inte sv.


26 aug 2008, 16:01
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Okej. Jag tror jag prövat det tidigare, men nu ändrat det till se. Ska starta om när jag fixat färdigt en sak.

Medans jag har hållit på och försökt fixa det hela på egen hand har jag råkat ta bort kombination av tangenter, och hittar inte var jag återställer detta. Jag kan till exempel inte göra é, utan får ´e när jag försöker.


26 aug 2008, 16:57
Profil ICQ
Användarvisningsbild

Blev medlem: 27 mar 2006, 21:32
Inlägg: 3330
Ort: Stockholm / Tumba
OS: Linux Mint
Utgåva: 16.04 Xenial Xerus LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Hej Jojan,

är du säker på att du använder rätt tangent till é?
"Blippen" efter/till höger om tangenten för ä, ger automatiskt det du skriver att du har.
Väljer du motsvarande tangent, men den som följer uppe på den numeriska raden, efter 0, + och sedan ' ,
ger dig é, men, i en "tvåstegsraket". Först trycka tecknet, ingen synbarlig reaktion på skärmen, sedan den sökta bokstaven,
i detta fall e och vips, så står där é.

Funkar det inte hos dig, ja då är det något som inte är som det skall vara. Dessvärre har jag inte fler lösningar för stunden.

Hälsar
Tukken

_________________
Ubuntu med både Gnome och Mate. Kör mestadels med LinuxMint Cinnamon till vardags. Våren 2019.


26 aug 2008, 17:49
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Att ändra till se fungerade bra.

Jag vet att jag använder rätt kombination av tangenter, och jag vet också att jag har pillit i inställningar för att få bort det. Den brevid ä ger ' (apostrof) och den mellan backspace och + ger ´ (accent) som man ska ha för att få é (som jag inte får) genom kombination av först ´ och sedan e.


26 aug 2008, 19:27
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Jag gissar att du har råkat aktivera inställningen nodeadkeys.


26 aug 2008, 19:35
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 08:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Jag hade också problem med é ('e) men gjorde så här:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
# Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Då blev det OK.

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


26 aug 2008, 19:54
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
webaake skrev:
Jag hade också problem med é ('e) men gjorde så här:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
# Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Då blev det OK.

Kopierade av exakt och det bliev ingen skillnad.


26 aug 2008, 23:27
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Det är bra om du listar dina tangentbordslayout-inställningar:

Kod:
xprop -root | grep -i xkb
gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


26 aug 2008, 23:50
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Kod:
jojan@x:~$ xprop -root | grep -i xkb
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "se", "", "lv3:ralt_switch"
_XKB_RULES_NAMES(STRING) = "xorg", "dell", "se", "", "lv3:ralt_switch"

jojan@x:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = []
 model = dell
 options = []
 overrideSettings = true


27 aug 2008, 01:14
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Inget konstigt där vad jag kan se. Kolla även detta:

Kod:
setxkbmap -print

Och vad säger xev om tangenterna?


27 aug 2008, 09:26
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Kod:
jojan@x:~$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+se+inet(dell)+level3(ralt_switch)"  };
        xkb_geometry  { include "pc(pc104)"     };
};

xev
Kod:
KeyPress event, serial 26, synthetic NO, window 0x3600001,
    root 0x57, subw 0x0, time 7433412, (173,476), root:(178,524),
    state 0x10, keycode 21 (keysym 0xfe51, dead_acute), same_screen YES,
    XLookupString gives 2 bytes: (c2 b4) "´"
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: True

KeyRelease event, serial 29, synthetic NO, window 0x3600001,
    root 0x57, subw 0x0, time 7433502, (173,476), root:(178,524),
    state 0x10, keycode 21 (keysym 0xfe51, dead_acute), same_screen YES,
    XLookupString gives 2 bytes: (c2 b4) "´"
    XFilterEvent returns: False

KeyPress event, serial 29, synthetic NO, window 0x3600001,
    root 0x57, subw 0x0, time 7433898, (173,476), root:(178,524),
    state 0x10, keycode 26 (keysym 0x65, e), same_screen YES,
    XLookupString gives 1 bytes: (65) "e"
    XmbLookupString gives 1 bytes: (65) "e"
    XFilterEvent returns: True

KeyPress event, serial 29, synthetic NO, window 0x3600001,
    root 0x57, subw 0x0, time 7433898, (173,476), root:(178,524),
    state 0x10, keycode 0 (keysym 0xe9, eacute), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 2 bytes: (c3 a9) "é"
    XFilterEvent returns: False

KeyRelease event, serial 29, synthetic NO, window 0x3600001,
    root 0x57, subw 0x0, time 7433976, (173,476), root:(178,524),
    state 0x10, keycode 26 (keysym 0x65, e), same_screen YES,
    XLookupString gives 1 bytes: (65) "e"
    XFilterEvent returns: False


27 aug 2008, 18:55
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Det där ser också ut som det ska. Vad var det egentligen du pillade med när det slutade fungera? scim?


27 aug 2008, 22:05
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
SCIM kan det ha varit. Det kom upp helt plötsligt som en ikon i notifieringsytan. Jag trodde jag bara tog bort det, men det kan ha varit pillande där. Känner inte till programmet så väl, såni får hjälpa till här också, tack.


28 aug 2008, 13:41
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Rensa isf bort alla scim-inställningar, dvs ta bort ~/.scim helt och hållet.


28 aug 2008, 13:46
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Det enda som hände är att SCIM-ikonen kommer fram igen.


28 aug 2008, 14:25
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Jojan skrev:
Det enda som hände är att SCIM-ikonen kommer fram igen.

Avinstallera scim och ta bort ~/.scim igen.


28 aug 2008, 14:35
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Konservburk skrev:
Jojan skrev:
Det enda som hände är att SCIM-ikonen kommer fram igen.

Avinstallera scim och ta bort ~/.scim igen.

Borttaget, omstartad och ingen skillnad.


28 aug 2008, 21:41
Profil ICQ
Användarvisningsbild

Blev medlem: 07 apr 2007, 21:28
Inlägg: 5919
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Jojan skrev:
Borttaget, omstartad och ingen skillnad.

Ja du, nu har jag inga fler idér på lager :P

Möjligtvis att man kan felsöka det hela genom att starta en ren X utan några program, inte ens gnome eller någon fönsterhanterare. Funkar det då så är det bara att starta program efter program tills det slutar fungera... och där har vi isf ringat in problemet.


28 aug 2008, 23:34
Profil
Användarvisningsbild

Blev medlem: 18 nov 2007, 21:47
Inlägg: 95
Ort: Huddinge / Stockholm / Sverige
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Å, ä, ö borta vid start.
Ett steg närmare då. Loggar jag in i "Felsäker Terminal" kan jag göra teckenkombinationerna.


29 aug 2008, 01:57
Profil ICQ
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 38 inlägg ]  Gå till sida 1, 2  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 5 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
cron
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011