Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 08 apr 2020, 04:02



Svara på tråd  [ 9 inlägg ] 
 [LÖST(?)]Hjälp ubuntu startar inte! 
Författare Meddelande
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg [LÖST(?)]Hjälp ubuntu startar inte!  Tråden är löst
När jag försöker starta ubuntu hänger den sig i uppstarten när den arbetar med usb (även i recovery mode). Det går inte ens att chroota sig in på den via en live-skiva
Kod:
ubuntu@ubuntu:~$ sudo chroot /media/disk/
chroot: kan inte köra kommando "/bin/bash": Formatfel på körbar fil

Jag tror att det behövs en ominstallation, snälla bättre ide någon?
om jag måste installera om vill jag göra det utan att formatera. Är det möjligt med en alternative skiva eller finns det andra sätt?


Senast redigerad av Rasmus 18 jun 2009, 15:36, redigerad totalt 1 gång.



11 jun 2009, 15:15
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Tillägg.
Den hänger sig på usbhid nånting, när jag drar ut tng bord samt mus hänger den sig istället på nått med filesystem.
Felet komm efter att jag tryckt in uppdateringar (både med apt-get upgrade och apt-get dist-upgrade)
Går det att rädda? Jag har en massa program som jag patchat för att funka med all hårdvara samt lite annat som skulle vara jobbigt att försöka återskapa.


11 jun 2009, 21:40
Profil

Blev medlem: 20 aug 2007, 07:11
Inlägg: 411
Ort: Slite, Gotland
OS: Ubuntu
Utgåva: 19.04 Disco Dingo
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Det hänger sig för mig med när jag startar med 2.6.30, men funkar när jag startar med 2.6.28-11 så prova med det.


13 jun 2009, 11:21
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Varken 2.6.28-11, 2.6.29-4, 2.6.30-6 eller 2.6.30-7-rw funkar (det är alla jag har)


13 jun 2009, 11:25
Profil

Blev medlem: 12 dec 2006, 23:20
Inlägg: 6633
Ort: /Dalarna/Hedemora/
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Enklast är nog om du chrootar in och drar in en ny kärna. Borde ju ha släppts nån uppdaterad version, så det är nog bara "apt-get update && apt-get upgrade" som vanligt.

_________________
Home sweet ~/ = http://sandnabba.se


15 jun 2009, 00:11
Profil WWW
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Det går ej att chroota in
Kod:
rasmus@rasmus-desktop:~$ sudo chroot /media/disk

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for rasmus:
chroot: kan inte köra kommando "/bin/bash": Formatfel på körbar fil


15 jun 2009, 07:51
Profil

Blev medlem: 12 dec 2006, 23:20
Inlägg: 6633
Ort: /Dalarna/Hedemora/
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Citat:
Formatfel på körbar fil


Verkar ju inge vidare, korrupt disk? Eller försöker de att chroota in på en 64 bits-installation från en 32 bitars?

_________________
Home sweet ~/ = http://sandnabba.se


17 jun 2009, 17:14
Profil WWW
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
Emil.s skrev:
Citat:
Formatfel på körbar fil


Verkar ju inge vidare, korrupt disk? Eller försöker de att chroota in på en 64 bits-installation från en 32 bitars?

Ee, "ubuntu 7.10 for your pc" står det på den. Den kanske är 32bitars...
Kod:
uname -m
i686
:-[
När jag bootar arch nästa gång ska jag se om det går bättre :P


17 jun 2009, 17:20
Profil
Användarvisningsbild

Blev medlem: 07 sep 2006, 18:33
Inlägg: 2291
Ort: Svalsta
OS: Ubuntu
Svara med citat
Inlägg Re: Hjälp ubuntu startar inte!
När jag skulle lägga in mini.iso på ett usbminne (med unetbootin) och sedan skulle starta på usbminnet startade han istället denna installation. :o
Kod:
rasmus@rasmus-desktop:~$ uname -a
Linux rasmus-desktop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

Hur det gick till har jag ingen aning om. Tillråga på allt använder an "fel" /home,
denna install ligger på /dev/sda1 och tillhörande /home på /dev/sda2 men nu använder den /dev/sdb11 som /home. Vilkent är /home till min 32bitars installation som ligger på /dev/sdb10.

En till sak, jag hade tagit bort grub till denna installation. På /dev/sda ligger grubb till Arch och på /dev/sdb ligger grub till 32 bitars ubuntu.

Någon som vet hur detta har gått till? Jag klagar inte, men det är minst sagt märkligt.
Dessutom skulle jag vilja veta hur jag får in mini.iso på ett usbminne så att jag kan installera från det, utan att komma till denna installation istället ;)


18 jun 2009, 15:33
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 9 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011