Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 01 okt 2020, 02:34



Svara på tråd  [ 21 inlägg ]  Gå till sida 1, 2  Nästa
 Få D-Link dwa 140 att fungera? 
Författare Meddelande
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
 Få D-Link dwa 140 att fungera?  Tråden är löst
Hallå,

D-Link USB DWA 140 ska det teoretiskt bara vara att plugga in i datorn och börja surfa med. Men nu när jag köpt den inser jag att det inte var så enkelt. Det verkar dessutom vara många som har problem. Mitt krux är att jag inte ens kan se tillgängliga nätverk. Jag har inte installerat någon drivrutin. De drivisar jag har är till PC. Någon som vet hur jag får igång den?

Jag har hittills försökt med följande instruktioner: viewtopic.php?f=208&t=46685&p=375744

Plus att jag försökt med en del engelska guider. Jag använder Karmic.


Senast redigerad av bios 13 jul 2010, 01:56, redigerad totalt 1 gång.



12 apr 2010, 21:28
Profil
Användarvisningsbild

Blev medlem: 20 aug 2007, 13:33
Inlägg: 750
Ort: Upplands Väsby
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Eftersom jag satt med samma pryl i helgen min första fråga
- har du version B2 eller någon annan?

I alla fall i Intrepid och 9.04 så räcker inte rt870sta för version B2 utan du måste ta hem och kompilera en kärnmodul för rt3070 samt blacklista allt som har beteckningen 2870.

http://doc.ubuntu-fr.org/dwa-140&ei=zjh ... %26hl%3Den
http://translate.google.com/translate?h ... dwa-140_b2
var den mest hjälpsamma sidan.

http://ubuntuforums.org/showthread.php?p=9068760
http://ubuntuforums.org/showpost.php?p= ... stcount=35

_________________
~~~ Kubuntu18.04 ~~~


13 apr 2010, 09:39
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Hej och tack för återkoppling! Min heter dock enbart D-Link Wireless N USB Mini Adapter DWA 140 och verkar inte vara av versionen B2. Jag ska ta en titt på länkarna du bifogade.

- Rättelse - det är visst B2 jag har.


13 apr 2010, 20:26
Profil
Användarvisningsbild

Blev medlem: 20 nov 2007, 20:32
Inlägg: 46
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Tjena!
För mig räckte det med att öppna /etc/modprobe.d/blacklist.conf som root och lägga till raden

blacklist rt2800usb

och sen reboot!
mvh. Tomas


13 apr 2010, 20:46
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
alatariel skrev:
Eftersom jag satt med samma pryl i helgen min första fråga
- har du version B2 eller någon annan?

I alla fall i Intrepid och 9.04 så räcker inte rt870sta för version B2 utan du måste ta hem och kompilera en kärnmodul för rt3070 samt blacklista allt som har beteckningen 2870.

http://doc.ubuntu-fr.org/dwa-140&ei=zjh ... %26hl%3Den
http://translate.google.com/translate?h ... dwa-140_b2
var den mest hjälpsamma sidan.

http://ubuntuforums.org/showthread.php?p=9068760
http://ubuntuforums.org/showpost.php?p= ... stcount=35



Om jag förstår det hela rätt så börjar jag under rubriken "D-Link DWA-140 B2, Automated method" när man scrollat ner till mitten av sidan, eftersom jag har B2? Sedan hoppar jag över det automatiserade scriptet eftersom jag bara får meddelandet "sh: Can't open dwa140b2.sh". Annars så ska det scriptet göra hela processen om jag förstår rätt? Men eftersom jag inte får det att funka så gör jag det manuellt med instruktionerna som följer efter det? Antar jag...?


13 apr 2010, 21:07
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
mcnuggz skrev:
Tjena!
För mig räckte det med att öppna /etc/modprobe.d/blacklist.conf som root och lägga till raden

blacklist rt2800usb

och sen reboot!
mvh. Tomas



Hallå Tomas. Jag har testat det flera gånger och startar därefter om, drar ur nätverkskabeln när datorn satt igång och sätter in USB:et. Inget händer förutom att jag saknar internetuppkoppling. Lampan på USB:et lyser inte heller vilket bör betyda att datorn inte finner den. Något jag missat?


Mvh David


13 apr 2010, 22:37
Profil
Användarvisningsbild

Blev medlem: 20 nov 2007, 20:32
Inlägg: 46
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Du glömmer väl inte att spara blacklist.conf efter du lagt till raden va?
Eftersom du har gjort det flera gånger menar jag :D


13 apr 2010, 22:56
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
mcnuggz skrev:
Du glömmer väl inte att spara blacklist.conf efter du lagt till raden va?
Eftersom du har gjort det flera gånger menar jag :D


Nädå :) Har till o med öppnat och kollat så att det verkligen blivit sparat.

Men det är alltså det enda du gjort? Ingen installation av drivisar eller programvara?


13 apr 2010, 23:05
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Är det förresten värt att vänta och se om den funkar med Lucid? Eller finns något som vet en surfsticka som verkligen garanterat funkar med Ubuntu? Den bör klara uppåt 100 mbit.


13 apr 2010, 23:12
Profil
Användarvisningsbild

Blev medlem: 20 nov 2007, 20:32
Inlägg: 46
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
 Re: Få D-Link dwa 140 att fungera?
Jag har testat hur mycket grejer som helst men den här gången tror jag inte jag har lagt nåt som ska påverka det..
Testa lägga in linux-backports-modules-karmic annars, funkade hyffsat för mig innan.


13 apr 2010, 23:25
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Har testat att lägga in backports oxå...Så vitt jag förstod skulle backports bara installeras o det var allt? Ingen konfigurering eller så?


14 apr 2010, 12:24
Profil
Användarvisningsbild

Blev medlem: 20 nov 2007, 20:32
Inlägg: 46
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Eventuellt en reboot eller starta om WiFi..


14 apr 2010, 12:36
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Nu har jag laddat in Device Manager som visar att systemet faktiskt noterar nätverks-USBn. Sedan har jag testat ndiswrapper. Den anger drivrutinen för Win XP som jag valt att installera, och sedan "Hårdvara i systemet: Ja". Men när jag anger "Konfigurera nätverk" får jag: "Kunde inte hitta ett nätverkskonfigurationsverktyg."

Går det att dra någon vettig slutsats utifrån detta?


14 apr 2010, 22:11
Profil
Användarvisningsbild

Blev medlem: 20 aug 2007, 13:33
Inlägg: 750
Ort: Upplands Väsby
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Ndiswrapper använde jag aldrig.
Inte något skript heller.
9.04 på en kompis dator.

lsusb var: ID 07d1: 3c0a D-Link System
dvs en ver B2

Jag följde helt enkelt den franska översatta sidans steg till punkt och pricka!

* laddade ned drivrutinen för 3070,
* la till raden med GPL per instruktionerna på den franska sidan ( i filen os / linux / usb_main_dev.c)
* kompilerade och installerade den,
* skapade rätt mapp enligt instruktionen (/etc/Wireless/RT2870STA/) och kopierade in filen RT2870STA.dat i den mappen) - allt enligt instruktionen
* blacklistade *allt* som har med andra drivisar att göra i en blacklist.conf-fil i /etc/modules.d
typ

blacklist rt2800usb
blacklist rt2x00usb
blacklist rt2x00lib
blacklist rt2870sta

* lade till att rt3070sta laddas vid start i /etc/modules
och efter en omstart lyste den snällt upp när man pluggade in den och anslöt i NetworkManager utan problem!

_________________
~~~ Kubuntu18.04 ~~~


16 apr 2010, 09:43
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Seriöst alatariel, du är kvällens hjälte!!! Nu är jag up and running och slipper ha en jäkla kabel över halva lägenheten. Najs, najs, supernajs :) Tack!


17 apr 2010, 00:56
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Hmmm...nu får jag ett annat problem. Det jag gjorde var att gå till http://translate.google.com/translate?h ... dwa-140_b2 och välja scriptet som gjorde installationen automatiskt eftersom jag använder Karmic (under rubriken "Automated method" på mitten av sidan).

Allt funkade perfekt tills jag startade om datorn. Inga nätverk visades överhuvudtaget och den kände inte av USBn. Först efter att jag kört scriptet igen funkade allt som det skulle. Under "Automated Method" på länken ovan har jag inte gjort allt som står under "Prerequisites". Det kanske jag måste göra?

Något förslag någon?


17 apr 2010, 09:59
Profil
Användarvisningsbild

Blev medlem: 20 nov 2007, 20:32
Inlägg: 46
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
konstigt att du måste köra med den drivrutinen, jag kör rt2870?
vad får du för hastighet osv? funkar allt kanon?


17 apr 2010, 14:48
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Jag följde ju mest instruktionerna och har inte ifrågasatt drivaren. Men hittills har den funkat toppenbra, dock med problemet att allt måste göras om när jag startar upp datorn igen.


17 apr 2010, 16:08
Profil
Användarvisningsbild

Blev medlem: 02 sep 2007, 13:07
Inlägg: 129
OS: Ubuntu
Utgåva: 19.10 Eoan Ermine
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Nu har löst problemet delvis att datorn inte verkar finna USBn när jag startar på nytt. För att dra igång den skriver jag sudo insmod /lib/modules/2.6.31-20-generic/kernel/drivers/net/wireless/rt3070sta.ko

Hur gör jag för att datorn ska göra detta automatiskt varje gång jag loggar in?


18 apr 2010, 16:59
Profil
Användarvisningsbild

Blev medlem: 20 aug 2007, 13:33
Inlägg: 750
Ort: Upplands Väsby
OS: Kubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Få D-Link dwa 140 att fungera?
Vill du ha det vid uppstart av datorn, lägg (som root) till raden

rt3070sta

i filen
/etc/modules

---
Info: (kör du
Kod:
insmod
måste du ange hela sökvägen såsom du har gjort, moduler i /etc/modules läses in medelst
Kod:
 modprobe
och då räcker modulnamnet om den modulen inte ligger i en mycket obskyr mapp i /lib/modules-trädet) - vill du absolut köra insmod, försök med (som root) att lägga till din rad till en fil (som förmodligen inte finns utan måste skapas)
Kod:
gksu gedit /etc/rc.local
och gör den filen körbar medelst
Kod:
sudo chmod 755 /etc/rc.local


D-Link dwa-140 Ver B2 kräver rt3070, det räcker inte med rt2870 för den som frågade - kolla vad lsusb ger för resultat och checka på den franska sidan.

Obs! Tänk på att du måste kompilera om kärnmodulen ifall du uppgraderar kärnan! obs!

_________________
~~~ Kubuntu18.04 ~~~


19 apr 2010, 09:23
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 21 inlägg ]  Gå till sida 1, 2  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
cron
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011