Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 04 jun 2020, 07:13

Kategoriregler


Läs följande innan du postar: viewtopic.php?f=208&t=44692
Du får hjälp att komma igång med Ubuntu genom att välja en personlig fadder här: viewtopic.php?f=110&t=8767



Svara på tråd  [ 21 inlägg ]  Gå till sida 1, 2  Nästa
 Ubuntu 10.04, Nordea, Nexus Personal och Firefox 
Författare Meddelande

Blev medlem: 04 jan 2008, 14:03
Inlägg: 4613
OS: Ubuntu
Svara med citat
 Ubuntu 10.04, Nordea, Nexus Personal och Firefox  Tråden är löst
Jag får inte e-legitimation på fil från Nordea att fungera med Firefox 3.6.8 och Nexus Personal 4.15.0.14 i Ubuntu 10.04.

1. Jag började med att ladda ner Nexus Personal för Linux här: https://install.bankid.com/installbankidcom/

2. Därefter installerar jag Nexus Personal med: sudo ./install.4.15.0.14.sh i

3. Sedan provar jag att starta Firefox, varpå webbläsaren kraschar istället för att starta upp som vanligt. Jag gör då så här: http://support.mozilla.com/tiki-view_fo ... &forumId=1

4. Därefter startar jag Firefox (vilket alltså fungerar igen efter stegen i guiden på Mozillas hemsida) och loggar in på mitt konto på Nordea.

5. På Nordea klickar jag på "e-legitimation" och "fil". Då kommer det här felmeddelandet upp: http://img64.imageshack.us/i/bankidnordea.png/

Jag har accepterat nordea.se i NoScript och jag har stängt av Adblock på Nordea.

Varför fungerar inte Nexus Personal och bankid i Nordea på Ubuntu 10.04 och Fx 3.6.8?


Senast redigerad av ubot 19 aug 2010, 20:24, redigerad totalt 1 gång.



10 aug 2010, 13:08
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Jag har inte testat bankid själv men jag tror att du behöver java och att du ska ha sun-java6-plugin installerad och aktiverad.


11 aug 2010, 12:16
Profil
Användarvisningsbild

Blev medlem: 05 apr 2009, 15:11
Inlägg: 291
Ort: Södra Bohuslän
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
BankiD-programvaran Nexus Personal har inget java-beroende! Att installera Java-miljö från Sun är helt onödigt ur ett BankID-perspektiv.

Kolla in tråden "GUIDE: Installera BankID utan Firefox 3.6.6-krascher" http://ubuntu-se.org/phpBB3/viewtopic.php?f=19&t=49532

För övrigt pågår det ett arbete med att sammanställa problem och lösningar för BankID, se viewtopic.php?f=223&t=49825

@mcNisse: Om du inte använder BankID själv så tycker jag att du inte skall ge råd och speciellt inte sådana råd som är irrelevanta.


11 aug 2010, 14:00
Profil

Blev medlem: 04 jan 2008, 14:03
Inlägg: 4613
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Tackar för svaren. Jag använder bankid genom min Windows-installation tills vidare. Jag har inte tid och lust att trixa med det här just nu. Jag använder e-legitimation så sällan och har ändå dual-boot då jag fick XP med datorn så inte så svårt att använda Windows dom få ggr jag behöver använda e-leg. Principiellt är det ju fel att man behöver gå omvägen om ett annat os för att få bankid från Nordea att fungera i Ubuntu, men, men...


13 aug 2010, 08:44
Profil

Blev medlem: 08 jun 2010, 08:06
Inlägg: 13
Ort: Nacka
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
:) Hej!

E-leg på fil? Menar du ett så kallat mjukt certifikat?

Om du menar det, rekommenderar jag dig att kontakta ditt närmaste Nordeakontor för ett hårt certifikat. Det innebär att du får en dosa och ett kort som du använder för att få tillgång till e-leg. Det vet jag att det fungerar. Jag har prövat det med Nordea och Handelsbanken.

Då är det bara att du följer de steg som du beskrev. Installera BankID (Nexus är vad jag förstår Nordeas etikett på det hela). Installera drivrutiner för kortläsaren. Plugga in kortläsaren. Vänta någon minut. Starta om. Ja, det är lite Windowsaktigt, men då är det säkrast att det fungerar. Stoppa in ditt hårda certifikat (kortet) i kortläsaren och logga in med din kod.

Personligen föredrar jag Handelsbanken. De har ett uttalat stöd för Linux. Eller snarare ett OS-oberoende av deras Internettjänst.

//Leopold

_________________
Dator:
HP DC 5100 MT, Pentium 4 3 GHz, 2 GB Ram, 160 GB HDD


14 aug 2010, 09:56
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Får man två kort med certifikat?
Jag har hört talas om en person som fick sitt kort uppätet av en bankomat precis innan han skulle betala räkningarna.........


14 aug 2010, 10:07
Profil

Blev medlem: 08 jun 2010, 08:06
Inlägg: 13
Ort: Nacka
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
mcNisse skrev:
Får man två kort med certifikat?
Jag har hört talas om en person som fick sitt kort uppätet av en bankomat precis innan han skulle betala räkningarna.........


Hm? Det låter som en dålig ursäkt för att säga att man inte har pengar ::) .

Hos Handelsbanken får man ett kort specifikt för inloggning på Internetbanken. Du kan inte använda det i en affär eller ta ut pengar i en bankomat.

Hos Nordea kan du få ett specifikt kort. Jag är dock osäker då jag lagt Nordea i malpåse. Jag har ett inloggningskort för att kunna se mitt banksaldo. Tidigare använde jag mitt Visa-kort för e-leg inloggning.

Danske Bank kör med Java och ett separat dosa. Danske Bank är nog enklast att använda på Linux. Installera Java och du är klar att logga in. Och så är de billigast överlag, för privatkunder. Jag tycker om Danske Bank.

_________________
Dator:
HP DC 5100 MT, Pentium 4 3 GHz, 2 GB Ram, 160 GB HDD


14 aug 2010, 10:22
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
leopoldb skrev:
Hos Handelsbanken får man ett kort specifikt för inloggning på Internetbanken. Du kan inte använda det i en affär eller ta ut pengar i en bankomat.


Det låter bra. Jag har handelsbanken men kör fortfarande med skrapkoderna för internetbanken. Det fungerade tom i konqueror, men nu kan jag inte logga in med konqueror utan tvungen att köra firefox :(


14 aug 2010, 14:13
Profil

Blev medlem: 08 jun 2010, 08:06
Inlägg: 13
Ort: Nacka
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
mcNisse skrev:
leopoldb skrev:
Hos Handelsbanken får man ett kort specifikt för inloggning på Internetbanken. Du kan inte använda det i en affär eller ta ut pengar i en bankomat.


Det låter bra. Jag har handelsbanken men kör fortfarande med skrapkoderna för internetbanken. Det fungerade tom i konqueror, men nu kan jag inte logga in med konqueror utan tvungen att köra firefox :(


Hej Nisse!

Då rekommenderar jag dig att snarast pallra dig iväg till ditt Handelsbankkontor och skaffa e-leg på kort. Säkrare och mindre att skrapa upp :) .

//Leopold

_________________
Dator:
HP DC 5100 MT, Pentium 4 3 GHz, 2 GB Ram, 160 GB HDD


14 aug 2010, 16:59
Profil
Användarvisningsbild

Blev medlem: 18 okt 2009, 11:50
Inlägg: 1824
Ort: Gränsfors
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
ubot skrev:
Tackar för svaren. Jag använder bankid genom min Windows-installation tills vidare. Jag har inte tid och lust att trixa med det här just nu. Jag använder e-legitimation så sällan och har ändå dual-boot då jag fick XP med datorn så inte så svårt att använda Windows dom få ggr jag behöver använda e-leg. Principiellt är det ju fel att man behöver gå omvägen om ett annat os för att få bankid från Nordea att fungera i Ubuntu, men, men...


Det är huuuuuur enkelt som helst att få till detta :) Och jag fattar inte varför folk inte har postat lösningen till dig! Så här kommer den:

Citat:
Gå till: https://install.bankid.com/installbankidcom
Gå igenom installationen vilket du redan har gjort...
Installera sen: sudo rm /usr/local/lib/personal/libP11.so && sudo apt-get install libp11-1


Sen är det bara tuta och köra om du sitter på 32-bitars, sitter du på 64-bitars så är det en till liten genväg du måste ta för att få det att fungera =)

_________________
Webmaster för
Cracker.se Linux, IT-säkerhet, Mac & Boxee Box!

Mina guider
http://ubuntu-se.org/phpBB3/viewtopic.php?f=19&t=56551


14 aug 2010, 17:48
Profil WWW

Blev medlem: 19 aug 2010, 09:15
Inlägg: 6
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Helt fantastiskt Pontus!
Jag har provat allt som står i alla forum jag tittat i och så kör jag sudo apt-get install libp11-1 och nu funkar det.
Stooort tack!

Ubuntu 10.04 32-bit, Firefox 3.6.8


19 aug 2010, 10:30
Profil
Användarvisningsbild

Blev medlem: 18 okt 2009, 11:50
Inlägg: 1824
Ort: Gränsfors
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
AnAnSwe skrev:
Helt fantastiskt Pontus!
Jag har provat allt som står i alla forum jag tittat i och så kör jag sudo apt-get install libp11-1 och nu funkar det.
Stooort tack!

Ubuntu 10.04 32-bit, Firefox 3.6.8


Tackar tackar :)

_________________
Webmaster för
Cracker.se Linux, IT-säkerhet, Mac & Boxee Box!

Mina guider
http://ubuntu-se.org/phpBB3/viewtopic.php?f=19&t=56551


19 aug 2010, 11:31
Profil WWW

Blev medlem: 04 jan 2008, 14:03
Inlägg: 4613
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Pontus Öhman skrev:
AnAnSwe skrev:
Helt fantastiskt Pontus!
Jag har provat allt som står i alla forum jag tittat i och så kör jag sudo apt-get install libp11-1 och nu funkar det.
Stooort tack!

Ubuntu 10.04 32-bit, Firefox 3.6.8


Tackar tackar :)


Jaha. Nu använder jag bara e-legitimation 1 gång/halvår eller något så det spelar inte så stor roll. Jag har ju ändå dual-boot på datorn då XP följde med köpet. Jag tycker jag känner igen det där med att ta bort en .so grej, men inte att man ska installera något nytt. Aja, nästa gång det blir aktuellt att hämta e-leg så kanske jag gör ett nytt försök med kommandoraden du skrev också. Tackar för tipset!


19 aug 2010, 20:23
Profil
Användarvisningsbild

Blev medlem: 08 aug 2010, 15:53
Inlägg: 2
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox 3.6.8?
Pontus Öhman skrev:
Gå till: https://install.bankid.com/installbankidcom
Gå igenom installationen vilket du redan har gjort...
Installera sen: sudo rm /usr/local/lib/personal/libP11.so && sudo apt-get install libp11-1

Hej! Jag gjorde som Pontus sa och tog bort libP11.so och det gick bra. Men detta fungerade inte:

elin@Yoshi:~$ sudo apt-get install libp11-1Läser paketlistor... Färdig
Bygger beroendeträd
Läser tillståndsinformation... Färdig
Paketet libp11-1 är inte tillgängligt, men ett annat paket hänvisar till det.
Det kan betyda att paketet saknas, har blivit föråldrat eller endast
är tillgängligt från andra källor
Dock kan följande paket ersätta det:
libp11-0

Enligt utskriften verkar det som jag saknar en källa. Frågan är vilken och hur man lägger till den?

Vore tacksam för svar.

Ubuntu 9.10 32-bit, Firefox 3.6.8


21 aug 2010, 01:41
Profil
Användarvisningsbild

Blev medlem: 06 feb 2007, 20:51
Inlägg: 5211
OS: Debian
Utgåva: Vet inte/ingen utgåva passar
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
Paketet heter libp11-0 i karmic. Testa att installera det istället.


21 aug 2010, 08:49
Profil

Blev medlem: 06 nov 2009, 12:58
Inlägg: 3
OS: Ubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
Hej,

Jag har Ubuntu 10.04 och Firefox 3.6.8 och har testat ovanstående men får fortfarande samma meddelande på Nordea.

"Något av följande är inte uppfyllt:

* Din dator har inte en aktuell version av säkerhetsprogrammet Nexus Personal installerat.

* Din dator tillåter inte att en ActiveX-komponent körs. Ändra inställningarna i din webbläsare

* Din dator uppfyller inte de tekniska kraven för e-legitimation på fil."

Några tips?

Nordea måste vara sveriges mest efterblivna bank när det handlar om IT-lösningar (har god lust att byta).


23 aug 2010, 20:21
Profil
Användarvisningsbild

Blev medlem: 18 okt 2009, 11:50
Inlägg: 1824
Ort: Gränsfors
OS: Ubuntu
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
robbanl skrev:
Hej,

Jag har Ubuntu 10.04 och Firefox 3.6.8 och har testat ovanstående men får fortfarande samma meddelande på Nordea.

"Något av följande är inte uppfyllt:

* Din dator har inte en aktuell version av säkerhetsprogrammet Nexus Personal installerat.

* Din dator tillåter inte att en ActiveX-komponent körs. Ändra inställningarna i din webbläsare

* Din dator uppfyller inte de tekniska kraven för e-legitimation på fil."

Några tips?

Nordea måste vara sveriges mest efterblivna bank när det handlar om IT-lösningar (har god lust att byta).


Testa med: https://addons.mozilla.org/sv-SE/firefox/addon/59/

_________________
Webmaster för
Cracker.se Linux, IT-säkerhet, Mac & Boxee Box!

Mina guider
http://ubuntu-se.org/phpBB3/viewtopic.php?f=19&t=56551


23 aug 2010, 20:34
Profil WWW

Blev medlem: 01 okt 2010, 14:10
Inlägg: 1
OS: Kubuntu
Utgåva: 6.06 Dapper LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
Thanks for sharing this post

_________________
testking 70-653 | testking MB2-631 | testking 70-293 | testking 70-294


01 okt 2010, 14:16
Profil

Blev medlem: 17 okt 2010, 22:04
Inlägg: 1
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
Hej,
jag har också Nexus bekymmer.
Kör: 10.04 LTS, Firefox 3.6.18 , Nexus 4.15.0.14
Vid inloggningsförsök redirectas jag till "https://install.bankid.com/bank"
Har: - ominstallerat Nexus, -kört ditt skript Pontsu (sudo rm /usr/local/lib/personal/libP11.so && sudo apt-get install libp11-1).
Får svaret att den inte hittar libP11.so
Har testat att installera 11-1, får då svaret
"libp11-1 är redan den senaste versionen"

Ser dock inte den i utforskaren. Dock ser jag libplugins.so.
Q1 Är det den som skall bort kanske ?

Har även testa Epiphany, då kommer Nexus inloggningsrutan upp men finn släpper inte in mig ändå. Troligen för att Epiphany inte supportas.

Såg att Nexus endast stöds av 3.0, så det blir väl kanske att nedgradera.
Q1 Hur nedgraderar man till Firefox 3.0 ? Kan inte hitta 3.0 "force vesion" i synaptic.

Tacksam för svar.


17 okt 2010, 22:41
Profil

Blev medlem: 29 apr 2011, 22:19
Inlägg: 5
OS: Ubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Ubuntu 10.04, Nordea, Nexus Personal och Firefox... [LÖS
Hej!

Efter mycket trasslande har jag nu fått mitt BankID att fungera! Jag gick igenom en mängd trådar på detta forum samt Wikisidan och testat alla tips jag kommit över, men till ingen framgång. Jag började skriva ett inlägg här, och i den processen lyckades jag lösa problemet. :) Då jag inte har sett denna lösning på detta forum så postar jag mitt inlägg ändå, i fall någon annan har användning av informationen.

Jag använder Ubuntu 10.04 LTS, som jag håller uppdaterad, på en vanlig 32-bit PC (x86).

Kod:
simon@struts:~$ uname -a
Linux struts 2.6.32-31-generic #61-Ubuntu SMP Fri Apr 8 18:24:35 UTC 2011 i686 GNU/Linux


Min bank är Handelsbanken. Jag loggar in med kort och dosa utan anslutning, inga problem där. Det jag vill kunna använda är e-legitimationstjänster som Försäkringskassan, CSN och Skatteverket. Detta fungerar inte. Det går bra att installera Nexus Personal (4.7.0.11), "BankID Security Application" startar fint. Det är Firefox-pluginen som inte verkar fungera - ingen Nexus Personal dyker upp i Tools - Add-ons eller about:plugins.

Bild

Firefox är version 3.6.17. När jag startar firefox från kommandoraden ser det ut så här:

Kod:
simon@struts:~$ firefox
LoadPlugin: failed to initialize shared library /usr/local/lib/personal/libplugins.so [/usr/local/lib/personal/libplugins.so: failed to map segment from shared object: Permission denied]
LoadPlugin: failed to initialize shared library /usr/local/lib/personal/libplugins.so [/usr/local/lib/personal/libplugins.so: failed to map segment from shared object: Permission denied]
LoadPlugin: failed to initialize shared library /usr/local/lib/personal/libplugins.so [/usr/local/lib/personal/libplugins.so: failed to map segment from shared object: Permission denied]
LoadPlugin: failed to initialize shared library /usr/local/lib/personal/libplugins.so [/usr/local/lib/personal/libplugins.so: failed to map segment from shared object: Permission denied]


Detta antar jag är pudelns kärna. Då jag googlar efter "failed to map segment from shared object: Permission denied" och nexus personal hittar jag denna tråd på ett tyskt Ubuntu-forum. Min tyska på gymnasienivå är knagglig, men jag lyckades tyda att problemet har att göra med något som heter AppArmor. (Om man kör apparmor_status kan man se om detta används på ens eget system.)

Lösningen är att editera filen /etc/apparmor.d/usr.bin.firefox:

Kod:
sudo gedit /etc/apparmor.d/usr.bin.firefox


Och infoga dessa rader:

Kod:
/usr/local/lib/personal/* m,
/usr/local/lib/personal/personal.sh Uxr,
owner @{HOME}/.personal/config/Personal.cfg k,
/usr/local/lib/personal/config/Personal.cfg wk,


De ska ligga (antog jag, och verkar stämma) någonstans innanför sektionen som börjar med
Kod:
/usr/lib/firefox-3.6.17/firefox-*bin {

och innan den avslutande
Kod:
}
- men inte inuti någon av "child profiles". Jag lade dem just innan stycket "Child profiles".

Sedan startas AppArmor om med
Kod:
sudo /etc/init.d/apparmor reload
- och presto! När jag startar Firefox finns nu Nexus bland plugins:

Bild

Och fungerar perfekt! Tjoho! :)

Vore intressant att höra om det är något speciellt som gör att detta problem uppstod för mig, medan andra verkar ha ett fungerande Nexus Personal utan att ha genomfört dessa ändringar. Finns det en annan lösning på samma problem?

Tillägg 2011-10-17: Det verkar som att filen /etc/apparmor.d/usr.bin.firefox skrivs över när Firefox uppgraderas? Jag var i alla fall tvungen att göra om ändringarna... :-( Måste finnas ett "rätt sätt" att göra detta på...


Senast redigerad av skagedal 17 okt 2011, 21:08, redigerad totalt 1 gång.



01 maj 2011, 21:19
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 21 inlägg ]  Gå till sida 1, 2  Nästa

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
cron
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011