Visa obesvarade inlägg | Visa aktiva trådar Aktuellt datum och tid: 12 jul 2020, 05:17



Svara på tråd  [ 10 inlägg ] 
 Enable Numlok 
Författare Meddelande
Användarvisningsbild

Blev medlem: 17 apr 2010, 13:28
Inlägg: 53
Ort: Höör
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Enable Numlok
I äldre ubuntu kunde man installera Numlok. Då behövde man inte trycka på Numlok när man loggade in. Jag har försök installera installera Numlok både på 13.10 ock 14.04. När jag loggar in blir allt svart. Jag fick starta upp i recovery, där kunde jag ta bort filen jag skapade. /etc/lightdm/lightdm.conf
Det är inget större besvär att trycka på Numlok, men ibland glömmer man det.
Finns det ett annat sätt att starta Numlok från början.
Tacksam för svar

_________________
MAN MÅSTE LÄRA SIG KRYPA INNAN MAN KAN GÅ!


02 apr 2014, 14:24
Profil

Blev medlem: 31 okt 2008, 16:25
Inlägg: 2449
OS: Ubuntu
Svara med citat
Inlägg Re: Enable Numlok
Hej har du provat göra så här för att få numlock att vara aktiverat vid systemstart? https://help.ubuntu.com/community/NumLock


03 apr 2014, 00:53
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 09:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Enable Numlok
Ett alternativ är numlockx.
Efter installation kan man autostarta det på flera sätt - från .xinitrc, eller från /etc/X11/Xsession.d/.

Exempel: i mappen /etc/X11/Xsession.d/ skapar man filen 55numlockx. I den skriver man in;
Kod:
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF


Att skriva i /etc/X11/Xsession.d/ kräver admin/root-behörighet.

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


03 apr 2014, 10:53
Profil
Användarvisningsbild

Blev medlem: 17 apr 2010, 13:28
Inlägg: 53
Ort: Höör
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Enable Numlok
Tack för era svar.
Tyvärr antec. Jag gjorde som det stod, men det hjälpte inte.

webaake Den filen fanns redan. Därför skrev jag ingenting.

55numlockx-filen ser ut så här:
# X session startup script: /etc/X11/Xsession.d/55numlockx

# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
case $NUMLOCK in
# 'keep' is an undocumented state (see `man 1 numlockx'), though
# /etc/default/numlockx mentions it; do nothing
keep)
return 0
;;
off|on|toggle)
;;
*)
NUMLOCK=on
ltd=/usr/sbin/laptop-detect
[ ! -x $ltd ] || ! $ltd || NUMLOCK=off
;;
esac
$nlx $NUMLOCK || :
}

# EOF

_________________
MAN MÅSTE LÄRA SIG KRYPA INNAN MAN KAN GÅ!


05 apr 2014, 23:24
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 09:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Enable Numlok  Tråden är löst
Om du har numlockx installerat så testa
numlockx on &

I terminalen. Funkar det så är det bara att få det att autostarta nånstans ifrån. Det i sin tur beror på vilket DE du kör - googla!

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


06 apr 2014, 09:11
Profil
Användarvisningsbild

Blev medlem: 17 apr 2010, 13:28
Inlägg: 53
Ort: Höör
OS: Ubuntu
Utgåva: 20.10 Groovy Gorilla
Svara med citat
Inlägg Re: Enable Numlok
Tack så mycket. Det gick bra. :D

_________________
MAN MÅSTE LÄRA SIG KRYPA INNAN MAN KAN GÅ!


09 apr 2014, 20:51
Profil
Användarvisningsbild

Blev medlem: 09 maj 2007, 09:46
Inlägg: 3962
OS: Xubuntu
Utgåva: 20.04 Focal Fossa LTS
Svara med citat
Inlägg Re: Enable Numlok
Gôtt!

_________________
Xubuntu på flera maskiner. Men inte Unity!
Mer Terminalanvändande i Ubuntu vore bra. Och Xfce. Och Mate.


09 apr 2014, 21:18
Profil

Blev medlem: 25 feb 2008, 01:29
Inlägg: 279
Ort: Norrbotten
OS: Lubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Enable Numlok
tommybe1 skrev:
Tack så mycket. Det gick bra. :D


Du får gärna berätta mer utförligt hur, terminalkommandon.... :D

PS
Det verkar som design slynglana (för att prata med Påvel ;) eller vilka det nu är hittar nya sätt att dj...las med oss som använder rekommendationen att ha både siffror och andra tecken i våra lösen ord vid varje ny dist >:D
Eller jobbar dom för att succesivt återinföra teleprinter o hålkort ???
DS

Mannen med käpphästen: numlock on redan vid installation p.s.s. som val av språk o tangentbord.

_________________
NilleB / Ubuntu 18.04. med Mate, LXDE


08 jul 2014, 10:08
Profil

Blev medlem: 25 feb 2008, 01:29
Inlägg: 279
Ort: Norrbotten
OS: Lubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Enable Numlok
Antec skrev:
Hej har du provat göra så här för att få numlock att vara aktiverat vid systemstart? https://help.ubuntu.com/community/NumLock


Även jag har testat tipset för Lightdm. =>
Numlock på i inloggnings skärmen.
Inloggning =>
Numlock av ???

_________________
NilleB / Ubuntu 18.04. med Mate, LXDE


11 jul 2014, 07:55
Profil

Blev medlem: 25 feb 2008, 01:29
Inlägg: 279
Ort: Norrbotten
OS: Lubuntu
Utgåva: 18.04 Bionic Beaver LTS
Svara med citat
Inlägg Re: Enable Numlok
webaake skrev:
Ett alternativ är numlockx.
Efter installation kan man autostarta det på flera sätt - från .xinitrc, eller från /etc/X11/Xsession.d/.

Exempel: i mappen /etc/X11/Xsession.d/ skapar man filen 55numlockx. I den skriver man in;
Kod:
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF


Att skriva i /etc/X11/Xsession.d/ kräver admin/root-behörighet.


Min 55numlock, med Webaake's tips:

# X session startup script: /etc/X11/Xsession.d/55numlockx

# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
case $NUMLOCK in
# 'keep' is an undocumented state (see `man 1 numlockx'), though
# /etc/default/numlockx mentions it; do nothing
keep)
return 0
;;
off|on|toggle)
;;
*)
NUMLOCK=on
ltd=/usr/sbin/laptop-detect
[ ! -x $ltd ] || ! $ltd || NUMLOCK=off
;;
esac
$nlx $NUMLOCK || :
}

# Webaake's tips 140703
# X session startup script: /etc/X11/Xsession.d/55numlockx

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on || /bin/true; fi

# EOF

EOF

=>
numlock på i inloggningsskärm.
inloggn => numlock blinkar till men förblir på ;D

Men går det att kommentera bort original raderna med numlock rappakaljan ???

Sätter min egen tråd Numlock ..... igen igen igen, som löst med hänvisning hit.

Edit:
Nu for den lede i mig och jag kommenterade bort original numlock rappakaljan.
Och se numlock blinkar inte längre till och förblir på 8)

Min hypotes är att de raderna har lagts till av en MS infiltratör ;D

_________________
NilleB / Ubuntu 18.04. med Mate, LXDE


11 jul 2014, 08:30
Profil
Visa inlägg nyare än:  Sortera efter  
Svara på tråd   [ 10 inlägg ] 

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 0 gäster


Du kan inte skapa nya trådar i denna kategori
Du kan inte svara på trådar i denna kategori
Du kan inte redigera dina inlägg i denna kategori
Du kan inte ta bort dina inlägg i denna kategori
Du kan inte bifoga filer i denna kategori

Sök efter:
Hoppa till:  
cron
Main Engineer for phpBB3: Bertie at phpBB.com © 2000 - 2002, 2005 - 2007, the Group behind the Open Source code of phpBB.
Designed by STSoftware, modified by Katt, Konservburk & Peetra. Swedish translation by Peetra & phpBB Sweden © 2006-2011